View Issue Details

IDProjectCategoryView StatusLast Update
0006742MediaMonkey (current)Podcastspublic2011-03-02 22:43
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS7OS Version-
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006742: Podcast UI issues
DescriptionThere are several small UI issues in Podcasts handling:
1. An attempt to Subscribe to a Podcast that doesn't exist (URL isn't accessible) causes showing of 2 error dialogs - both showing the same content.
2. Podcast Subscription List isn't updated on:
 2a. Podcast Addition
 2b. Podcast Deletion
 2c. As a special case of 2a, if no Podcasts are subscribed and the list is expanded, the plus sign disappears and on a new Subscription it doesn't appear until MM restart.
3. Unsubscribe dialog always appears in the top-left corner of screen.
4. On Subscribe, the dialog defaults to
  [x] Customize subscription rules...
 I think that it should rather be unchecked by default (and preferably the controls below would be hidden in such a case).
TagsNo tags attached.
Fixed in build1351

Activities

Ludek

2010-11-28 21:42

developer   ~0021509

Fixed in build 1329.

lowlander

2011-02-10 22:28

developer   ~0023007

Last edited: 2011-02-10 22:39

View 2 revisions

1) Fixed
2a) Fixed, except when subscribing to invalid Podcast (http://me.com/index.xml)
2b) Fixed, leaves tree without focused node
2d) Location isn't updated when subscribing to a Podcast
3) Fixed
4) Fixed


5) Podcast URL can't be edited, but doesn't show disabled: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=55664 Ability to edit would be preferred.

Ludek

2011-02-11 02:04

developer   ~0023009

Last edited: 2011-02-11 02:09

View 2 revisions

2a) Yes, this is intended to not subscribe invalid podcasts

2d) I don't understand what you mean by "Location isn't updated"

5) Fixed in build 1349

lowlander

2011-02-11 02:22

developer   ~0023011

2a) The subscription to the invalid Podcast does happen and collapse/expand will show it in the Subscription node.

2d) Under the Podcast > Location node the new folder doesn't show automatically when it's created by adding a new Podcast.

lowlander

2011-02-16 01:45

developer   ~0023129

5) Verified in 1349

stephen_platt

2011-02-16 03:12

developer   ~0023133

2a) Can't reproduce in 1349

lowlander

2011-02-16 18:15

developer   ~0023163

2a)
- Expand Subscriptions tab
- Right click > Sunscribe to New Podcast
- Subscribe to http://me.com/index.xml or http://www.mediamonkey.com/podcast.xml
- Add Title and Description
- Click OK
- Click OK in error box
- Notice new subscription not listed in Subscriptions node
- Collapse/Expand Subscriptions node
- Notice new subscription is listed

peke

2011-02-16 22:47

developer   ~0023188

Confirmed on Lowlander steps.

Ludek

2011-02-17 01:49

developer   ~0023206

Thanks, you are right.

BTW: If I think about it, MM should add and focus even currently inaccessible podcast URLs (the server might be just down for whatever reason and user wanted to subscribe it immediatelly)

Fixed in build 1350.

lowlander

2011-02-22 02:36

developer   ~0023290

Verified in 1350, subscribing to invalid podcast works as expected.

6) When subscribing to a Podcast in the Podcast node (Right click on Subscription node) it will focus on the new Podcast subscription in the Entire Library node. I think it should focus on the subscription in the current Collection.

Ludek

2011-02-22 21:16

developer   ~0023327

Fixed in build 1351.

jiri

2011-02-23 12:01

administrator   ~0023340

4. Is fixed now, but it results in a lot of empty space in the dialog. What should happen is to resize the dialog in this case. (Alternatively, the checkbox could be converted to a button and open a new dialog, but the current solution is probably better).

Ludek

2011-02-23 15:05

developer   ~0023345

Fixed in 1351.

lowlander

2011-02-23 17:16

developer   ~0023350

4) I would go with resizing the dialog, there is enough proliferation of dialog boxes in MediaMonkey as it is. Alternatively showing all the options but disabling them has the benefit that the user sees what options are available.

lowlander

2011-03-02 22:43

developer   ~0023511

Verified in 1351.