View Issue Details

IDProjectCategoryView StatusLast Update
0006686MediaMonkey (current)Framework: Taggingpublic2011-01-13 00:42
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006686: Tag field: Parental Rating
DescriptionParental Rating should be supported for Videos. For most formats, the tag is standardized as a text field, except for MP4 which uses numeric identifier which maps to predefined values.

The approach that can be used is the same approach that MM uses for ID3v1 genres. i.e. list any genres that aren't used, but are predefined by the tag format in Grey. Any values that aren't pre-defined by the tag format shouldn't be prepopulated, because otherwise, users get annoyed that the fields aren't removed from the dropdown list in the Properties dialog.

Re. MP4/conversion to MP4, don't bother with any special logic to convert the field value--it's impossible to do accurately.
TagsNo tags attached.
Fixed in build1338

Activities

michal

2010-11-26 13:16

developer   ~0021487

Last edited: 2010-11-26 13:17

View 2 revisions

Format plugins part is implemented, assigning to Ludek to make MM (GUI) part.

Ludek

2010-12-01 08:56

developer   ~0021532

Fixed in build 1330.

rusty

2010-12-06 21:01

administrator   ~0021630

Tested 1331.

The field exists in the Advanced tab, however, it's not implemented as a dropdown as I would have expected. i.e. shouldn't a dropdown be used to let the user choose predefined (greyed out if unused) MP4 tag values, or previously used values for non-MP4 tracks ?

michal

2010-12-11 14:59

developer   ~0021733

MP4 rating field differentiates only "clean" content (val=2), "explicit" content (val=4) and "None" (val=0 or not set). I think, it is quite far from typical parental rating (G, PG, PG-13, R, NC-17, unrated), should we set this value at all?

Ludek

2010-12-11 17:12

developer   ~0021734

Last edited: 2010-12-11 17:13

View 3 revisions

So maybe just [G, PG, PG-13, R, NC-17, unrated] should be added to the combo as default values OR no default values as Michal suggests?

Also adding new query field would be useful so that users could define Auto-Playlist/Collection based on Parental Rating?

michal

2010-12-11 18:29

developer   ~0021737

No "no default", I suggest [G, PG, PG-13, R, NC-17, unrated] too.

rusty

2010-12-12 03:47

administrator   ~0021750

Re. MP4, it's strange because iTunes does support much more granular parental controls; I suppose it just saves them to the library.

Re. defaults, I'm going to suggest no defaults because they differ by country, and it would be annoying e.g. for a German person to see default values based on US standards if none of their Files possessed those ratings.

michal

2010-12-12 16:59

developer   ~0021776

rusty: where could I find parental control of a video file in iTunes? I did not find any in "Get Info" dialog.

rusty

2010-12-13 18:47

administrator   ~0021789

In itunes it doesn't appear to be in the track properties, but rather in Edit > Preferences > Parental Control (i.e. it's most likely in the DB only, or in tags that aren't exposed to the user).

michal

2010-12-13 19:31

developer   ~0021792

I see, it looks that it is related mainly to Apple Store and their shopping DB, iTunes does not set this field at all.
So assigning back to Ludek to implement dropdown with previously used values.

Ludek

2010-12-20 19:56

developer   ~0021963

Last edited: 2010-12-20 21:12

View 2 revisions

Fixed in build 1338

peke

2011-01-13 00:42

developer   ~0022341

verified 1343