View Issue Details

IDProjectCategoryView StatusLast Update
0006642MediaMonkey (current)Playlist / Searchpublic2011-02-07 05:21
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006642: Search Dialog needs to be updated to support Collections
DescriptionThe search dialog currently doesn't explicitly indicate what it's searching, nor does it allow the user to configure what Collection to search.

Both the basic and advanced tabs should default to the default settings that are configured in the search tab, but allow the user to configure 'Entire Library' or a specific Collection.
TagsNo tags attached.
Fixed in build1324

Relationships

related to 0006509 closedLudek Playlists should display using appropriate view settings 

Activities

stephen_platt

2010-11-04 12:08

developer   ~0021168

Last edited: 2010-11-04 12:11

View 2 revisions

I guess you're talking about 'Advanced search' (ie after clicking the search icon) so maybe this should be in its own ticket, but it would be nice to make the search bar "Firefox style" like outlined here:
http://www.mediamonkey.com/forum/viewtopic.php?f=9&t=36392#p188794

This follows a logical workflow: first, we choose "Search mechanism"; then we type; then we do the search.

It seems related because the collection could be picked from the drop down menu but feel tree to move to own ticket if necessary.

Ludek

2010-11-05 10:56

developer   ~0021191

I think, this should be based on 0006509 and 0006610

So my UI suggestion (to be consistent with 0006509) is following:


Search: _Music_______[v] collection
---------------------------
|Basic|Advanced|
Match [All] of the following criteria:
......

[Clear] [OK] [Cancel]



and the corresponding collection would be pre-selected based on 0006610, i.e. if the user has "Current Collection" search mode and actually is in a Music collection node then 'Music' is pre-filled to the Search dropdown (otherwise 'Entire Library')

Agreed?

rusty

2010-11-05 12:54

administrator   ~0021192

Sounds good.

Ludek

2010-11-08 13:00

developer   ~0021245

Ok, I am just thinking about one more thing, because we try to make this consistent with 0006509 then we should also change it for AutoPlaylists from current:
View as: _Music_______[v] collection
--->
Search: _Music_______[v] collection

and if we would also do the following change for playlists:
View as: _Music_______[v] collection
--->
View under: _Music_______[v] collection

then we could move Playlists node under the individual collections and Playlists node would became a subnode of each of the collection (the same we have already done with Podcasts Subscription List).

Supposing that this could be a big change at this point, we should at least do the change for Auto-Playlists from current "View as:" to "Search:"

Agreed?

rusty

2010-11-08 17:12

administrator   ~0021249

You're right that all (AutoPlaylists, Playlists, and Search) should be consistent. As I think about it, though, the intent for:
- AutoPlaylists is to allow the user to choose how the playlist should display (and optionally limit tracks to a collection)
- Playlists is to allow the user to choose how the playlists should display
- Search is to allow the user to limit tracks to a collection and use the associated view

With that in mind, I like your initial idea. i.e.
-For Search: Search: _______ collection
-For AutoPlaylists: Search: _______ collection

Re the idea that
-For Playlist: View as: _________ collection

I disagree, because Playlists can span multiple collections, and I think that at least for now, we should maintain the Playlists node external to Collections.

Currently, Autoplaylists show: 'Display as Collection:'_____________^

Ludek

2010-11-10 14:26

developer   ~0021286

Fixed in build 1324.

stephen_platt

2011-02-07 05:21

developer   ~0022880

verified 1346