View Issue Details

IDProjectCategoryView StatusLast Update
0006632MediaMonkey (current)Synchronizationpublic2011-06-05 01:46
Reporterjiri 
PriorityurgentSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006632: Aspect Ratio conversion configuration improvements
DescriptionThe current state is as follows:

1.
[ ] Stretch video to fit size
 - This forces video to be resized to the designated dimensions even if smaller. E.g., if video is 320x240, it's resized to 640x480, even though it certainly doesn't mean any quality increase.

2.
[x] Preserve aspect ratio
 - Preserves aspect ratio of the converted video - this is almost always expected to be turned on, might be needed to be turned off in some specific cases, like somehow damaged video or so.


I would suggest to get rid of 1., since it doesn't add any real value and only requires user to understand the concept. I think that we should separate two cases.
a. Ordinary conversion: In this case video should _always_ be converted to the required dimensions ('Max. size' field), i.e. it should even be upscaled, without any additional option needed. I'd also rename 'Max. size' to 'Dimensions' in this case.
b. Auto conversion: In this case video should _never_ be upscaled, since it doesn't seem to make sense for any type of device (only in case the supported formats indicate that there is some minimum video size expected, but it should happen automatically anyway then). In this case I'd rename 'Max. size' to 'Max. dimensions'.

2. This option could be left as is for now. In the future, we might want to change it to a drop-down, so that it covers the current two options (Keep AR, Stretch), but also adds Zoom, possibly also 'Smart Zoom' (intelligent resizing, as found on some 16:9 TVs for showing 4:3 content), etc. But this would be implemented only subject to device requirements.
TagsNo tags attached.
Fixed in build1334

Activities

jiri

2010-11-03 18:30

administrator   ~0021158

Assigning to Rusty for a review.

rusty

2010-11-04 14:31

administrator   ~0021170

Last edited: 2010-11-04 14:32

View 2 revisions

Here's what I'd intended:
Stretch video to fit size: does 2 things:
-For smaller videos, upscales, for devices that require the video to be an exact size.
-For larger and smaller videos, adds borders for cases where 'Preserve Aspect Ratio' is enabled, for devices that require the video to be an exact size.
So this option is only required for devices that have such limitations on video size (I don't know how many such devices exist. e.g. perhaps even iPods must have exact resolutions??).

Preserve Aspect ratio:
As you point out, it should almost always be enabled, except in certain cases.

So from my perspective, there would be a need for all four combinations of settings.

As far as your UI suggestion, I would agree on a change to the current UI as follows:
If 'Stretch video...' is enabled, show 'Resolution:'
If 'Stretch video...' is disabled, show 'Max. Resolution:'

Note: it might also be better to change 'Stretch video to fit size' to 'Fit size exactly'

jiri

2010-11-04 15:20

administrator   ~0021173

The things is that I don't think the first option is ever needed. Per the cases you mentioned:
1. This is covered by Supported formats - if there's a minimum width and height specified, MM should automatically comply to this (i.e. upscale smaller videos) and there's no need to add an option for this.
2. This is actually only a little more complicated version of 1. - if a device does have minimum and maximum width and height equal (i.e. there's only one supported resolution) in Supported formats, MM should automatically take care of adding black bars or whatever is necessary.

rusty

2010-11-04 16:26

administrator   ~0021174

1. Do we agree on the following?
-Some devices don't need to have the videos upscaled or black bars to be added (so stretch video can be disabled--there's no sense in upscaling or adding these bars if it's not required!)
-Some devices do require the video to be upscaled and black bars to be added (so stretch video can be enabled)
I don't know how many such devices fall into either category, though, but I expect that this should be configurable.

2. Are you saying that the auto-conversion _criteria_ affect the conversion format settings!? If that's the case, then we're kind of in agreement, except that I'm saying that the conversion format dialog needs to give the user the ability to change these settings (the conversion criteria are irrelevant to the conversion format settings).

jiri

2010-11-04 17:03

administrator   ~0021176

No, it isn't about auto-conversion criteria, but about Supported formats. I.e., if you configure for a device that it supports WMV, (min.160-max.320)x(min.120-max.240) resolution, 0-25 framerate, etc., these limitation are taken into account for the auto-conversion. So, regardless what you configure then as the target format, it should always comply to the limitations configured in Supported formats.

So, yes, we are in agreement re.1, but it can be fully automatic - in the example above, let's say that you configure the target format as 320x200, then if you convert 200x140 video - it isn't upscaled, but if you convert 100x50 video, it is automatically upscaled (since it doesn't fall into the supported range of the device).

rusty

2010-11-04 18:12

administrator   ~0021177

OK, I think I see. Since the 'Supported formats' screen now indicates what formats are supported by MM, the Auto-conversion dialog limits options to those formats that are supported, and will automatically determine whether to 'stretch' videos on conversion. So in such cases, the setting can be removed/hidden.

Note: there may be cases where the option is required (e.g. in cases where the user hasn't configured tho Supported formats / resolutions for the device), however, we'll see if this becomes an issue.

We'll retain the function on the manual Conversion dialog.

michal

2010-12-11 08:24

developer   ~0021730

Fixed in build 1334. Encoder part (possibility of black bars when resizing) fixed in codec packs 1.03.
Note - it is necessary to update both, MM and codec pack.

Stretching in autoconversions works automatically now, when needed, adds black bars, when necessary.
Black bars could appear also during manual conversion - when both checkeboxes are checked and destination dimensions does not match source aspect ratio.

peke

2011-06-05 01:46

developer   ~0025930

Verified 1384