View Issue Details

IDProjectCategoryView StatusLast Update
0006629MediaMonkey (current)DB/FileMonitorpublic2010-12-20 21:13
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006629: Scanning of UPnP servers doesn't work properly
DescriptionIf UPnP servers are scanned into the library, there aren't represented in a useful manner. We should either:
a) fix this
b) disable UPnP scanning until we fix this

Specific issues are:
1) A server entry is generated for every track scanned
2) Path format is confusing. It might be better to show something like \\UPnP\<server>\path
3) Spaces in the path/filename don't display in a 'friendly' manner.

See the attached screencap.
TagsNo tags attached.
Fixed in build1324

Activities

rusty

2010-11-02 21:24

administrator  

Upnp_in_library.jpg (200,414 bytes)
Upnp_in_library.jpg (200,414 bytes)

jiri

2010-11-02 23:33

administrator   ~0021131

1&2 should be fixed
3) This probably isn't urgent, but might be nice to be fixed. If we do so, we should probably implement this 'friendly' representation for any item represented by URL (i.e. including any HTTP streams), but not for ordinary files - so that e.g. %20 isn't replaced by ' ' there.

Ludek

2010-11-09 13:25

developer   ~0021271

Last edited: 2010-11-09 13:26

View 2 revisions

1) Fixed
2&3) I resolved this by presenting the actual URL path to the source which is e.g.
http://127.0.0.1:9000/disk/DLNA-PNMP3-OP01-FLAGS01700000/O0$1$8I104205.mp3
I think it is not meaningless, but rather useful now, because user can see the real path url and can test it with (transfer it to) another app.

Fixed in build 1324.

peke

2010-12-20 21:13

developer   ~0021978

Verified 1336