View Issue Details

IDProjectCategoryView StatusLast Update
0006565MediaMonkey (current)Properties/Auto-Toolspublic2010-12-17 01:37
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006565: Genres list should only show Genres used within a Collection
DescriptionIn build 4.0.0.1317, the Genres dropdown in the Properties dialog (and the dropdown in the Tracklist) display every single Genres, rather than just those used in the active Collection.

This is kind of annoying because e.g. if the user is classifying Classical Music, they would only want to see Classical Genres, and instead they see a bunch of irrelevant options.

The same holds true for movies/TV shows--users don't want to see 'Rock' when they're interested in choosing between Drama and Comedy.
TagsNo tags attached.
Fixed in build1318

Activities

jiri

2010-10-19 20:15

administrator   ~0020869

I hope that we are able to filter this out effectively. In case of some performance problems, we'd have to figure out some DB related improvement.

petr

2010-10-20 21:16

developer   ~0020887

Fixed in 1318

peke

2010-12-17 01:37

developer   ~0021882

Verified 1335