View Issue Details

IDProjectCategoryView StatusLast Update
0006545MediaMonkey (current)Main Panelpublic2010-12-20 03:50
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006545: Art View Performance / display issues
DescriptionIn the (Album) Art View, there are a couple of problems with how the thumbnails are rendered for video (leaving this all in one bug because the performance issues may involve tradeoffs in relation to the cosmetic issues):

1) performance is passable for Music Albums, but is so slow as to be unusable for video content. Just dragging the scrollbar down locks the MM UI as it loads up the artwork.

2) the video thumbnails don't look great, maily because:
- the thumbnails are different sizes, but we're trying to fit them in the squares that are used for Album Art (which is always a constant size).
- the thumbnails often have white lines between the image and their mirror

Suggestions for the cosmetic issue:
a) Generate thumbnails that are all the same vertical size (crop if necessary) OR Display the thumbnails so that they are all immediately above the associated text (the different vertical space between the images and the text contributes to the clutter). I suggest trying the latter first.
b) Get rid of the mirrored effect since it doesn't really work well when the mirror is so close in height to the image thumbnail (esp. if doing so improves performance, and also considering that this will solve the problem of white lines between the thumbnail and its mirror) for Collection where Type=video. Perhaps just use a shadow instead.
TagsNo tags attached.
Fixed in build1317

Relationships

related to 0006546 closedpetr Display of video content needs to be optimized in the Art view 

Activities

petr

2010-10-16 19:43

developer   ~0020792

Fixed in 1317.

peke

2010-12-20 03:50

developer   ~0021940

Verified 1336