View Issue Details

IDProjectCategoryView StatusLast Update
0006505MediaMonkey (current)Main Panel/Toolbars/Menuspublic2011-01-12 23:53
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006505: Tabs
DescriptionTabs, modeled after Chrome, are configurable (enabled by default) and eliminate much of the need for 'favorites' in the tree. Each tab is akin to a new MediaMonkey window--except that the tabs have no effect on the tracklist.
 
Users will create tabs for whatever locations/collections they use most commonly enabling them to 'pause' whatever they were doing within a particular Collection. All selections / column settings / view settings / tree positions within a tab should persist.
 
Tabs are globally enabled/disabled via the View > Tabs menu. When tabs are initially enabled, the 'Start' and '+' tabs appear. Pressing the '+' tab creates a new 'Start' tab populated via a language-dependent URL. See Media Jukebox for a similar implementation.
 
Tabs can also be enabled via a new right-click option on any top-level tree node: 'Open in new tab'. (low)
 
(#) D&D to tabs should work exactly as if the user drag and dropped a track onto the node that is active in the tree and/or the user can drop directly onto a tree location within the new tab.
TagsNo tags attached.
Fixed in build1332

Relationships

related to 0006547 closedpetr Some View settings don't persist as expected 
related to 0005925 closedpetr Main Panel: Tabbed views 
parent of 0006557 closedLudek Search configuration settings don't take effect until restart (regression) 
related to 0006529 new Right-click on nodes selects content, interfering with 'Open in new tab' function 
related to 0006898 closedpetr No Tooltip for + Menu button 
related to 0007296 closedpetr Click middle button should open new tab for the node that is currently hovered over 

Activities

rusty

2010-09-28 04:11

administrator   ~0020589

Tested in 1313. The only issues that remain are:
a) 'Open in new tab' for root nodes
b) D&D to a tab

petr

2010-10-04 20:17

developer   ~0020647

re a) implemented
re b) it should work same as when you're dragging a track into main tree node

rusty

2010-10-06 17:09

administrator   ~0020650

Last edited: 2010-10-06 17:58

View 2 revisions

Tested in 1314 and there are still a couple of tweaks required:
a) open in new tab works strangely because right clicking on the tab causes the focus to change --> 2 tabs are open. e.g. if the user is currently in 'Music' and right-clicks on Podcasts --> initial tab changes to 'Podcasts' and new tab opens in Podcasts!

Right clicking on the tab shouldn't change the view.

b) I'm not sure exactly what has been implemented because I couldn't get this to work. To clarify the usecases that I would expect to work:
i) If a Playlist or Now Playing list is open, if the user drags a track to the tab, the track should be dropped into the Playlist/NP list.
ii) If a particular Collection is open, d&d should be the same as dragging into the collection (see 0006502). Similarly if a particular node is open, d&d shouldb e the same as dragging into the node.

Discussion point: Tabs currently display the title of the current node, however, this may not be the ideal means of titling a tab (e.g. 'Artist' or 'Year' do not convey much information about what is actually contained within a tab). Perhaps a better approach would be to display the title of the current _root_ node, and display a tooltip on mouseover that shows the full path (except in the case of playlists which should show the actual playlist, and in the case of UpnP servers, in which case the server name should be displayed). If we take that approach, then d&d should always be to the destination shown in the tab (rather than the node selected within the tab).

iii) If the d&d operation is invalid e.g. D&D to a tab for 'Entire library', UPnP, CD (unless we add support for CD burning via D&D to the node), My Computer, Net Radio, Web, then the cursor should indicate that the operation is invalid.

rusty

2010-10-07 21:22

administrator   ~0020660

Last edited: 2010-10-07 22:13

View 2 revisions

Re. a) The 'Open in new tab' functionality cannot be added until it's possible to right-click a node without selecting its content--otherwise two tabs of the node appear.

A hack could be to allow right-click of a node to not select the nodes' content for root nodes (except the CD and Devices nodes), however, that's inconsistent, in the sense that only some root nodes work this way, and in the sense that the function can be used if the user is deeper in the tree.

Opening a new bug to track this separately.

Re. bii) Petr suggested that perhaps the best approach is to display 'Root node..Current node', and d&d would function exactly as if the track(s) had been dropped into the node.

petr

2010-10-09 00:15

developer   ~0020688

All remaining issues fixed in 1315.

rusty

2010-10-15 20:49

administrator   ~0020784

Last edited: 2010-10-15 20:54

View 2 revisions

Tested 1316. A couple of issues still remain:
biii) D&D to a CD node should indicate that the operation is invalid

c) If the user opens a new tab for UPnP servers node, then switches to another tab, then back to the UPnP tab, the tab changes names!!

d) Tree structure doesn't persist within tabs. e.g.
i) in the Music tab, collapse the tree
ii) create a new tab for Classical Music
iii) in the Classical Music tab, expand the Classical Music node
iv) return to the Music tree --> the tree structure has changed!! i.e. the Classical Music node is expanded!

stephen_platt

2010-11-01 16:33

developer   ~0021110

e) Tabs can't be re-arranged. You should be able to click and drag a tab to reorder them.

rusty

2010-12-02 21:11

administrator   ~0021566

biii) moved to 0006791

c) still open in 1329.

d) still open in 1329

e) moved to 0006792

petr

2010-12-05 22:28

developer   ~0021610

c & d fixed in 1332

peke

2011-01-12 23:53

developer   ~0022330

c & d verified 1343