View Issue Details

IDProjectCategoryView StatusLast Update
0006487MediaMonkey (current)Now Playingpublic2011-04-12 22:04
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006487: Improved Album Art / Details dialog
DescriptionThe Album Art dialog should be improved as described at:
http://www.jirihajek.net/MMwiki/index.php/MM_4.0_UI#Now_Playing

The implementation in build 1312 looks great. Here are a few suggestions for further improvement:
1) a) The titlebar should be disabled by default (i.e. on a clean install).
   b) 'Show Titlebar' context-menu entry should be changed to 'Show Titlebar (move window)' (this will apply to all such strings, since we'll be disabling the titlebar elsewhere and users should be clear on how to move the window)
   c) 'Show file details' (instead of 'Show Track Details') should appear _immediately below_ 'Show Titlebar (move window)' in the context menu
   d) 'Choose fields' (instead of 'Configure Fields to Show') should appear immediately below 'Show file details' in the context menu. Note: this is probably going to have to be modified at some point since: i) the fields will differ depending on the file type (e.g. TV Shows should show 'Show', and then 'Episode' , whereas music should show 'Title', etc...).
   e) 'Fields Selection' dialog can be renamed to 'Choose fields...'
2) The Window should be moved to the right at the bottom of Now playing by default (i.e. on a clean install) since it gives more space to the Tree, and since the default player will no longer contain Album Art on the right side.
3) The tabs contain graphical artifacts that should be cleaned up
4) The thick black line below the tabs is kind of ugly--it should be replaced with a thin grey line that matches the tabs
5)a) The detail text should be aligned with the left edge of the line above it (currently it appears too far to the left).
  b) Also, there should be a bit of space between letters such as 'y' or 'p' and the Album art--currently the letters touch the AA.
  c) DreadM suggested that the text is too small. I disagree, but wonder if this should be configurable.
6) The right-click options to choose Now Playing vs Selected can be removed (since the tabs add this function)
7) The details fields shouldn't show anything if the field is empty ('unknown' just clutters the view).
8) The ratings field should display star ratings (currently it shows a number 0-100)
9) The list of fields shown to display doesn't seem to match other similar lists elsewhere in MM (see 0004681)
10) The 'Choose fields' dialog should be implemented with checkboxes instead. i.e. enable all fields to be displayed with checkboxes, and then use the arrows to change the order if needed. The current method is onerous.
11) It might be worth changing the dialog to 'Art & Details' instead of 'Album Art.'
TagsNo tags attached.
Fixed in build1333

Activities

petr

2010-09-25 23:25

developer   ~0020569

Last edited: 2010-09-26 15:37

View 2 revisions

Fixed in 1313.

rusty

2010-09-28 21:40

administrator   ~0020612

12) When a movie is playing/paused, the Album Art window no longer allows the user to choose 'Selected track'. The tabs shouldn't disappear when a video is played.

rusty

2010-10-12 21:18

administrator   ~0020739

Last edited: 2010-12-07 22:53

View 3 revisions

13) The space where track attributes display appears in white instead of the background color of the AArt window.

FIXED

rusty

2010-10-12 21:47

administrator   ~0020741

14) The ratings 'stars' appear vertically misaligned (the problem seems to get worse as the number of rows increases). See attached image.

rusty

2010-10-12 21:47

administrator  

rusty

2010-12-07 22:54

administrator   ~0021657

Last edited: 2010-12-07 22:55

View 2 revisions

15) The 'Choose Fields dialog' has fields with null values (see attached image). Raised to 'immediate' on account of this issue.

16) The Track# field displays 00 when the track# field isn't populated. Instead it just shouldn't appear.

rusty

2010-12-07 23:09

administrator  

petr

2010-12-08 14:36

developer   ~0021676

re 12) based on IM conversation with Jiri it would be better to hide tabs when video is playing in Art & details window (as is now)

petr

2010-12-08 15:10

developer   ~0021677

Fixed in 1333

rusty

2010-12-08 18:45

administrator   ~0021686

17) The Year field also shows '0000' when it isn't populated. It shouldn't appear if no value exists.

petr

2010-12-08 19:25

developer   ~0021688

Already fixed in 1333

peke

2011-04-12 22:04

developer   ~0024268

Verified 1363