View Issue Details

IDProjectCategoryView StatusLast Update
0006472MediaMonkey (current)Now Playingpublic2010-12-12 04:50
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006472: Now Playing Window should be aligned with tracklist window
DescriptionThe Now Playing window in MM4 isn't aligned with the tracklist window (i.e. the headers in each window are at different levels). There are a couple of potential solutions to this:

a) short term solution: in the default configuration, don't show the Now Playing Titlebar, and change the headers in the Now Playing Dialog so that they show: 'Now Playing (Title)' or 'Title (Now Playing)' instead of just 'Title'.
b) long term solution: Make the Now Playing window independent of the tracklist so that its buttons/menubar are aligned with the buttons/menubar of the tracklist. This is beneficial because:
i) the Now Playing list is independent of which Tracklist tab is selected
ii) the menu commands are optimized to the tracklist tab rather than to the playlist

If we go ahead with option b), we can also make the following improvements:
c) We can add controls in the Now Playing menu bar to switch between 'Now Playing' and 'Playlist'. This would give users the ability to D&D tracks to a specific position in a playlist _even_if_tracks are being played.
  
Note: the implementation of a dropdown in build 1311 includes the ability to select a playlist via a dropdown menu, and was intended to meet a similar need. The problem with the current implementation is that it doesn't allow for multiple playlists to be edited (e.g. Now Playing list, Burn List, other lists). Instead as soon as the user switches playlists, the Now Playing list is updated.

Original spec is at: http://www.jirihajek.net/MMwiki/index.php/MM_4.0_UI#Now_Playing

Updated spec for Option b) (incl. c)) is attached.

The simplest approach will likely be a) and to remove the dropdown.
TagsNo tags attached.
Fixed in build1314

Activities

rusty

2010-09-22 02:43

administrator  

NowPlaying_window_3.png.png (228,581 bytes)
NowPlaying_window_3.png.png (228,581 bytes)

petr

2010-09-27 22:16

developer   ~0020580

Implemented solution a. Will be in 1314.

peke

2010-12-12 04:50

developer   ~0021758

Verified 1334