View Issue Details

IDProjectCategoryView StatusLast Update
0006444MediaMonkey (current)Synchronizationpublic2010-10-26 23:19
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006444: Write only one album art file to a folder
DescriptionCurrently when a track has >1 album art image, we write all of them to a device (if synchronization is configured this way). This causes problem on Android phones, since anything else than albumart.jpg in a folder is considered to be an image and is shown in Gallery together with Photos.
TagsNo tags attached.
Fixed in build1318

Relationships

related to 0008478 feedbackLudek MediaMonkey (current) "Sync all artwork to file folders" option only syncs 1 image 
related to 0011919 assignedmarek MediaMonkey for Android Mixed up or Missing album art (Per-track Album Art) 

Activities

jiri

2010-08-17 16:36

administrator   ~0020451

Fixed in build 1310.

jiri

2010-08-17 16:36

administrator   ~0020452

Reminder sent to: Ludek

Ludek, please review this and let me know should you think this fix might cause a problem to some users.

peke

2010-08-20 00:09

developer   ~0020453

The only thing I would add is that we allow user to chose which one it will be used for albumart.jpg or set that Front Cover is used or if undefined first one is used.

Ludek

2010-10-14 10:42

developer   ~0020764

Last edited: 2010-10-14 12:26

View 3 revisions

Sounds good.
The first found 'Cover (Front)' is used, but if there is not a 'Cover (Front)' then nothing is copied.
This seems to be logical to me and generally should work fine for most of users.

Fixed in build 1317.

peke

2010-10-15 01:58

developer   ~0020777

If I understand it correctly now it works like:
- If 'Cover (Front)' exist then The first found 'Cover (Front)' is copied
- If there is no 'Cover (Front)' but there are existing images than First Defined is copied No matter what is it
- If there is no Defined Covers First one found is copied

Ludek

2010-10-15 13:09

developer   ~0020779

Last edited: 2010-10-15 13:11

View 5 revisions

No,
- If 'Cover (Front)' exists then the first found 'Cover (Front)' is copied
- If there is no 'Cover (Front)' then nothing is copied despite the fact there are any existing images

peke

2010-10-15 23:37

developer   ~0020786

I'm not sure that it is wise to not copy any Album arts if they exist but not defined. In that case I would rather send first one.

jiri

2010-10-18 20:37

administrator   ~0020838

I agree that in case there isn't any Front Cover, we should send the first image assigned to the track. It's probably better to have some image, than to have none.

Ludek

2010-10-19 09:47

developer   ~0020857

Fixed in build 1318.

peke

2010-10-26 23:19

developer   ~0020998

Verified 1318