View Issue Details

IDProjectCategoryView StatusLast Update
0006435MediaMonkey (current)Properties/Auto-Toolspublic2010-10-28 22:43
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS7OS Version-
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006435: Add video properties
DescriptionWe should add video properties to be shown in MM interface namely:
1. Dimensions - shown as e.g. 320x240 and sorted by a product of these two numbers
2. Bitrate - not a new field, just to show video bitrate here (including audio)
3. Framerate
4. Aspect ratio

These properties should have their columns in the main window and should be shown in Properties dialog - Details page (might need a little reorganization later).
TagsNo tags attached.
Fixed in build1316

Relationships

related to 0006394 closedpetr Automatic generation of video thumbnails 
related to 0006453 closedLudek Default video metadata is often missing / incorrect 

Activities

jiri

2010-08-11 16:14

administrator   ~0020443

Assigning to Ludek, since it's already internally in MM (by Michal), please consult Michal in case of problems.

Ludek

2010-08-30 13:34

developer   ~0020470

Last edited: 2010-08-30 13:35

View 2 revisions

I added them except for 'Aspect ratio', because most of players don't show the info and the info mostly corresponds to Dimensions fraction and in the others cases it can be hard to find the right info (as discussed with Michal).
We can add the Aspect Ratio later in case of need.

Fixed in build 1311.

Ludek

2010-09-05 22:21

developer   ~0020486

Last edited: 2010-09-05 22:21

View 2 revisions

Added Dimensions fraction to reflect the Aspect Ratio in build 1312, e.g:

Dimensions: [320x240 (4:3)]

Ludek

2010-10-12 12:28

developer   ~0020736

Last edited: 2010-10-12 12:29

View 2 revisions

Improved Aspect Ratio computing in build 1316 + added it also to tracklist to be shown in the Dimensions column as 320x240 (4:3)

peke

2010-10-28 22:43

developer   ~0021053

verified 1318