View Issue Details

IDProjectCategoryView StatusLast Update
0006379MediaMonkey (current)Synchronizationpublic2010-12-21 05:00
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006379: Tracks don't play from external drives (regression)
DescriptionThis is another regression most probably related to 0006317.

If user browses an external WMDM device/USB stick then the track are shown in tracklist as '\Music\Tracks\...' instead of 'E:\Music\Tracks\...' and thus don't play.
TagsNo tags attached.
Fixed in build1330

Relationships

related to 0006491 closedLudek MTP Devices should use root folder for in-place configuration 
child of 0006317 closedjiri Better support various types of devices for synchronization 

Activities

Ludek

2010-06-17 13:38

developer   ~0020266

Last edited: 2010-06-17 13:41

Also in MM 3.2 there is a similar report related to drive letter A: , more details and debug log in ticket ID: BFN-750884
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=9010

jiri

2010-06-28 11:53

administrator   ~0020298

Is this really a regression? We do show drive letters in paths, at least when the device plug-in knows them.

Ludek

2010-06-28 14:44

developer   ~0020304

Last edited: 2010-06-28 21:22

Yes, it is regression.

When an USB device is automatically detected by d_WMDM.dll plugin then it is shown directly in Main Tree as "Removable device (E:)". If user navigate by using that node then paths are like '\Music\Tracks\...' instead of 'E:\Music\Tracks\...' (works fine in 3.2.0.1294)

But if user navigates to "My Computer" -> "E:\" node then the path is correct,
i.e. 'E:\Music\Tracks\...'

I have just debugged it and the regression has been introduced in the SVN revision 9060.

In the concrete
procedure TDeviceData.GetUSBDevHandle;
fails the following line:
devlist := DeviceInterf.ActiveDeviceList[ USBID];

where (devlist.Count = 0) due to changes in SVN revision 9060.

Ludek

2010-10-10 23:34

developer   ~0020714

Fixed in build 1316.

rusty

2010-10-14 16:42

administrator   ~0020766

Verified 1316.

Ludek

2010-12-01 15:38

developer   ~0021535

Last edited: 2010-12-01 15:54

View 2 revisions

Re-opened, because this regression seems to be re-introduced, now the paths are like E:\E:\Music\Track.mp3

Fixed in 1330

rusty

2010-12-06 21:37

administrator   ~0021634

Verified 1331.