View Issue Details

IDProjectCategoryView StatusLast Update
0006330MediaMonkey (current)Conversion/Levelingpublic2010-10-13 01:43
Reporterpeke 
PrioritynoneSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version4.0Fixed in Version4.0 
Summary0006330: WAVE: 32Bit PCM and FLOAT can't be converted to FLAC
DescriptionWAVE Files in 32 BIT Formats can't be converted to FLAC and MM exits with error dialog that File is not created successfully.

According to http://flac.sourceforge.net/format.html#metadata_block_streaminfo althru FLAC support 32Bit current Encoder/Decoder do not support 32Bit and MM should notify user that Unsupported output/input format is selected to avoid confusion.

Samples are uploaded to FTP
Tagsdoc_faq, doc_help, todoc
Fixed in build1306

Activities

jiri

2010-04-15 15:18

administrator   ~0020102

Is the problem really on the encoding side? I.e. the WAVs can be decoded properly, right? If it's so, we should automatically downsample the audio to 24 bits and properly store it in FLAC. Feel free to assign to Michal then.

peke

2010-04-15 21:08

developer   ~0020105

Yes, MM properly decode and play 32Bit Wave Files.

Samples are supplied on FTP

Assigning to Michal

michal

2010-04-16 07:59

developer   ~0020108

I confirm, the problem is on the encoding side, MM tries to encode to 32 bit FLAC, but the encoder does not support it. Downsampling is needed.

michal

2010-04-16 09:27

developer   ~0020109

Fixed in build 1306. The audio above 24 bits will be automatically downsampled to 24 bits when converting to FLAC.

peke

2010-04-16 23:45

developer   ~0020110

Added tags so that users are noted about this change.

@michal
Can you test on all HD formats just in case like 192k

You can use http://www.wavosaur.com/download.php to create those WAVE files.

michal

2010-04-17 06:21

developer   ~0020111

peke: I have problems only with 64b, it is probably the same problem as in issue 0006331

peke

2010-04-17 18:28

developer   ~0020112

yes exactly, this is why I created two bugs.

So now WAVE -> FLAC should work like this in 1306 (For testing purposes):
16bit -> 16bit
24bit -> 24bit
32bit -> 24Bit
and
48 -> 48
96 -> 96
192 -> 192

peke

2010-10-08 23:40

developer   ~0020678

Verified 1314

Left as resolved so that Rusty can update Docs