View Issue Details

IDProjectCategoryView StatusLast Update
0006307MediaMonkey (current)Playerpublic2010-10-22 20:27
Reporterlowlander 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.1 
Target Version4.0Fixed in Version4.0 
Summary0006307: MM hangs when trying to play network files that are blocked by firewall
DescriptionSetup:
 - Windows XP Pro, MM 3.2
 - MM set to play Auto-Playlist using Auto-DJ, all tracks on QNAP NAS
 - Auto-Playlist is limited to 10 tracks
 - MM was closed on the Now Playing node
 
 Here's what I did:
 - Block my QNAP NAS in ZoneAlarm Free 8.0.298.000
 - Start MM
 - Start Play
 
 What happened:
 - Interface hangs
 - On non-debug that's all on debug version 4 MM error windows open and MM
 quickly alternates between them (thus not allowing user to submit them).
 - In both version I had to force exit of MM

Same test with Auto-DJ disabled:
- Still hangs
- No MM bug report windows open
TagsNo tags attached.
Fixed in build1305

Relationships

related to 0005458 closedLudek Firewall blocked stream access makes Player unresponsive 
related to 0007080 closedLudek MediaMonkey can't read tags for files on network shares/NAS 1342 (regression) 

Activities

2010-03-25 17:19

 

NetworkOfflinePlayTrackFail.LOG (422,652 bytes)

2010-03-25 17:19

 

NetworkOfflinePlayTrackFail-AutoDJoff.LOG (441,819 bytes)

Ludek

2010-04-01 14:35

developer   ~0020072

I can reproduce the issue, it takes 20 second to MediaMonkey to access the file. During that time the UI is frozen. Hard to do something about it, it is rather Windows issue. Also UI of Total Commander or Windows Explorer freezes when accessing the firewall blocked network area.

We need to access the tracks in order to get info about them, e.g. simple Win API's function GetFileAttributesW() causes the 20 seconds freeze (we need it to find out the file existence). We could change it and get info only from DB (for network tracks stored in DB), but it would cause unnecesarry regression for network tracks that can be accessed and aren't blocked by a firewall.

I think that the best soulution is to leave this unchanged and add a KB article.

Ludek

2010-04-01 18:06

developer   ~0020076

Last edited: 2010-04-01 19:59

Now, I found out more serious issue: MediaMonkey freezes on start up also if the network location is no longer accessible.

Steps to repro:
1. Run MM on your desktop computer
2. Play a song located on your laptop (i.e. from network location)
3. Close MediaMonkey on your desktop
4. Turn off your laptop
5. Open MediaMonkey on your desktop

=> MediaMonkey freezes and it takes 30 seconds to start, because it tries to access the inaccessible network location.

I think this needs to be fixed this way:
MM should access the network songs only when attempts to play them, scan them into MM library, rip them, convert etc.

But MM should not access them when starting.

Assigning to me in order to fix it.

Ludek

2010-04-01 20:50

developer   ~0020077

Last edited: 2010-04-01 20:51

Fixed in build 1305.

Because of risk of a regression I changed target version to 4.0.

jiri

2010-04-07 08:21

administrator   ~0020088

The code

  if (not CanAccessNetwork( FName)) then
    exit;

prevents GetFileInfo() from correct working on _any_ non-network track.

I temporarily disabled the code, until it's fixed.

Ludek

2010-04-07 09:19

developer   ~0020089

Fixed in build 1305.

peke

2010-10-22 20:27

developer   ~0020905

Verified 1317