View Issue Details

IDProjectCategoryView StatusLast Update
0006291MediaMonkey (current)Playerpublic2010-10-16 23:38
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target VersionFixed in Version4.0 
Summary0006291: Milkdrop causes MM crash while debugging
DescriptionOn Delphi 2010 and Win 7 while running MM in debugger, simply a click on the list of visualizations causes MM to crash (about 80% of time). I found out that it's caused by MilkDrop dll, which is loaded and unloaded at this moment. I added a short time solution to WinAmpPlugins.pas unit (see SVN commit) that prevents this by not unloading the dll, however we should locate the problem and fix it in Milkdrop.
TagsNo tags attached.
Fixed in build1303

Activities

michal

2010-03-07 21:09

developer   ~0020048

Fixed in build 1303. The problem was in using of one part of evallib, debugger in Delphi had problem with undeleted critical section for some reason.

peke

2010-10-16 23:38

developer   ~0020808

Verified 1316 SVN