View Issue Details

IDProjectCategoryView StatusLast Update
0000628MediaMonkey (current)Main Panel/Toolbars/Menuspublic2011-06-30 14:53
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0000628: Configurable Toolbar for Shortcuts (favorites)
Descriptionsee http://www.songs-db.com/forum/viewtopic.php?t=406&highlight=favorite+favourite

If there was a favorites node, then users could be given the option of adding favorites via an interface similar to 'Add Folders', in which they simply choose several favorite folders that should appear in the favorites node.

Another possible way of doing this is to allow the user to just define a set of shortcuts in a folder (like Vista does) and use those as the favorites, and expose them in the shortcuts toolbar.

Note: Favorites node could appear in both My Computer and Locations nodes OR it could just be a toolbar. TBD.
Additional InformationSource: http://www.songs-db.com/forum/viewtopic.php?t=164
TagsNo tags attached.
Fixed in build1398

Relationships

related to 0000553 closedpetr Enable Basic Tree / Column customization 
related to 0006504 newpetr Persistent tree nodes 
parent of 0005831 closedpetr Shortcuts toolbar missing handle 
parent of 0009215 closedLudek Empty dockable panel remains after some addon's uninstall [1422+] 
related to 0002806 closedpetr 'My Documents' folder isn't applicable to Vista 
related to 0004980 feedbackpetr Configurable toolbar of Now Playing window 
related to 0004826 closedpetr Customizeable toolbars 
related to 0006503 closedpetr Change Tree Shortcuts toolbar default settings 

Activities

rusty

2006-08-14 16:15

administrator   ~0007726

Note: Users often ask about this in relation to shortcuts to nodes rather than to individual tracks. In that light, it's almost like a magic nodes kind of function.

rusty

2010-10-15 18:09

administrator   ~0020783

Last edited: 2010-10-19 19:47

View 5 revisions

I would like to implement a very simplistic version of this functionality for MM4 using the Configure Toolbar functionality. i.e.

1) Make the Shortcuts toolbar configurable so that the user can choose which functions / shortcuts to different nodes should appear within it. That way, depending on how bug 0006504 turns out, we'll be able to set good defaults and users will be able to customize the toolbar to best meet their needs.

e.g. user should be able to configure links to Tree nodes, minimally: each collection, Playlist node, My Computer, Net Radio nodes.

2) Resolve 0005831 so that the shortcuts toolbar can be dragged next to the navigation toolbar, if needed.

Setting to 'high' for 4.0, pending user feedback.

The priority of this issue is dependent on whether 0006504 can be resolved. i.e. if it is completely fixed, this issue becomes a non-issue.

rusty

2010-10-21 14:26

administrator   ~0020891

Raising priority back to 'Urgent'. I just reviewed the 'Toolbar configuration' dialog, and it already supports the functionality being described! It's just a question of adding the Shortcuts toolbar to the Configuration dialog.

Note: it has buttons for 'Collapse the tree', 'Go to next view', 'Go to previous view', 'Go to My Computer node', 'Go to Now Playing node', 'Go to the radio node', 'Go to the Web node', 'Go to the Playlists node'. The only thing missing is shortcuts to individual collections, but we can do without that for now.

rusty

2010-10-27 22:17

administrator   ~0021031

This seems to have been fixed in build 1318, however, the fix is partial and introduced a regression: Upon editing the shortcuts toolbar, the main MM toolbar gets 'messed up'--all text descriptions disappear and it stops being context-sensitive.

To reproduce: edit the configuration of the shortcuts toolbar by deleting the 'Collapse' button.
--> Standard toolbar gets messed up.

rusty

2011-02-04 21:21

administrator   ~0022844

Note: in build 1346, there seem to be additional regressions: the shortcuts toolbar is removed from Toolbar configuration window!

rusty

2011-05-09 22:24

administrator   ~0024988

In 1371, this functionality (configurable toolbars) seems to be missing altogether!

petr

2011-05-10 11:45

developer   ~0024994

Work fine here. Anybody else have same problem ?

rusty

2011-05-11 05:07

administrator   ~0025063

Try a clean install on Win 7--no toolbars are listed in the left hand pane of the configurable Toolbars Window.

petr

2011-05-11 18:56

developer   ~0025090

Fixed in 1373

peke

2011-05-23 22:46

developer   ~0025596

Verified 1378

rusty

2011-06-27 21:13

administrator   ~0026398

This doesn't seem to be working correctly as described at:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=58870

Once the user modifies the shortcuts toolbar, it adjusts appropriately, but as soon as MM is restarted, the toolbar disappears entirely.

petr

2011-06-28 09:08

developer   ~0026404

Fixed in 1398

stephen_platt

2011-06-30 14:53

developer   ~0026473

verified 1398 in forum.