View Issue Details

IDProjectCategoryView StatusLast Update
0006277MediaMonkey (current)Tracklistpublic2010-10-27 12:42
Reportermichal 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target VersionFixed in Version4.0 
Summary0006277: Data type of the File Size field should be int64
DescriptionNow it is 32 bit integer and it is not sufficient for video files, they are often larger then 2GB.
TagsNo tags attached.
Fixed in build1308

Relationships

related to 0007173 closedLudek Error because VarType(SDBSongData.FileLength) = 20 while it should be = 3 as before 
related to 0007708 closedLudek FileLength is saved to DB as integer, it should be integer64. 

Activities

Ludek

2010-06-23 13:30

developer   ~0020281

Fixed in build 1308.

Now SD.FileLength and all related methods and variables are Int64 and thus can handle files > 4GB

peke

2010-10-27 12:42

developer   ~0021005

Last edited: 2010-10-27 12:42

View 2 revisions

Verified 1318