View Issue Details

IDProjectCategoryView StatusLast Update
0006251MediaMonkey (current)Framework: Taggingpublic2010-12-13 18:51
Reportermichal 
PriorityurgentSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006251: Tagging an image to FLAC files sometimes fails
DescriptionOne user reported problems with tagging FLAC files with AA. It appears when you have already some files queued for tagging and add AlbumArt to another album, then tagging of the first track of this album is problematic sometimes. The debug log indicates, that the problem could be in parallel processing, i.e. thread-safety...
I reproduced it by using external USB drive and one CPU core, so the tagging was not so fast and files were queued.
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=7542
TagsNo tags attached.
Fixed in build1301

Relationships

related to 0006973 closedLudek Tagging: Non library files do not get tagged with Album Art 

Activities

michal

2010-01-20 07:45

developer   ~0019963

Fixed in build 1301. The problem was more general, not only with FLAC and not only with the first track (it depended on the focused track during auto-tagging). But with FLAC it was easier to replicate (quite big files and then slower AA tagging, especially with USB disk).
The fix can be easily merged into 3.2 version too, but it requires more testing of regressions (auto-tagging, working with AA, tags).

peke

2010-10-10 02:12

developer   ~0020703

Is this merged into 3.2.x or?

michal

2010-10-10 05:32

developer   ~0020710

No, it is not.

michal

2010-12-13 18:23

developer   ~0021788

Resolving, fixed in target version.

peke

2010-12-13 18:48

developer   ~0021790

Last edited: 2010-12-13 18:50

View 2 revisions

THX Verified 1328