View Issue Details

IDProjectCategoryView StatusLast Update
0006246MediaMonkey (current)Properties/Auto-Toolspublic2011-01-10 10:31
ReporterLudek 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006246: Add 'Skipped #' column
Description1. Add new column/field 'Skipped #'
2. Add this field to advanced queries and auto-playlists
3. Add the field as new scripting properties to ISDBSongData COM interface
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=4&t=12948
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=19487&p=233577&hilit=skip+count#p233577
http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=16992&p=84543&hilit=skip+count#p84543
TagsNo tags attached.
Fixed in build1302

Relationships

has duplicate 0003041 closedjiri MediaMonkey (current) New DB Field: Skipped tracks counter 
related to 0007148 feedbackLudek MediaMonkey 5 Add 'Last Skipped' column 

Activities

rusty

2010-01-13 15:48

administrator   ~0019944

Last edited: 2010-01-13 15:52

I can see #skipped being useful, esp. for users who haven't rated their tracks.

It would be pretty important, though to define what a 'skip' is, and make sure that it's consistent with our definition of what a 'played' track is e.g. if the user listened to 7/8 of the track and then skipped it, it doesn't really mean the same as listening to 1/8 of the track and then skipping it.

jiri

2010-01-13 22:27

administrator   ~0019947

Ok, let's add it then. My point was, that such a field would lose its importance when e.g. some recommendation engine is implemented and so adding a new field would only mean increased memory requirements, etc.

As for 'skip' definition, we could probably say it's any pressing of Next button while only a very small (like <1/10?) part of the content has been played. I'm not sure about Stop button though, it probably shouldn't be considered as a 'skip' in any case.

Ludek

2010-01-14 10:36

developer   ~0019949

Last edited: 2010-01-14 10:49

I don't think that it's any pressing of Next button while only a very small (like <1/10) part of the content has been played.

I would rather say that skip is any pressing of Next button while (> 10 seconds) and (< 30 seconds) of the content has been played.

My point here is that if a user just fast switches between songs by repeatedly clicking next button then it shouldn't be considered as a skip, because by listening for just a second user hasn't listened to almost nothing so he cannot review if he likes it or doesn't like.

I have just tested iTunes and they implemented it similarly, i.e. something between 10 and 30 seconds of playback is considered as skip.

jiri

2010-01-14 11:53

administrator   ~0019951

I guess that it depends on user and tracks - sometimes user will even after 2-3 seconds realize that the track should be skipped, i.e. 1/10 of track would be too much for these purposes. Personally, I would set the interval to something like 2 seconds to 3/10 of length of a track.

Ludek

2010-01-15 00:40

developer   ~0019955

Last edited: 2010-01-15 00:59

Implemented in build 1301.

Interval set from 2 seconds to 3/10 of length of a track.

Added 'Skipped #' column, added 'Skip Counter' properties field, added 'Skipped #' advanced query condition, added to COM interfaces ( http://www.mediamonkey.com/wiki/index.php/ISDBSongData::SkipCount )

Ludek

2010-02-02 22:45

developer   ~0019994

Last edited: 2010-02-03 09:15

As noted here http://www.mediamonkey.com/forum/viewtopic.php?f=4&t=12948

Also an "OnTrackSkipped" or similar event should be added as well.

Fixed in build 1302 and documented here:
http://www.mediamonkey.com/wiki/index.php/ISDBApplicationEvents::OnTrackSkipped

stephen_platt

2010-10-25 13:25

developer   ~0020949

verified 1318

Mizery_Made

2011-01-10 07:29

updater   ~0022263

Based on the entry (in particular, the title), this feature has only been partially implemented. The "last skipped" information is still being requested (see here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=54850) and could prove useful. For instance, if someone is looking for something they haven't played in the last 30 days, they may also want to filter out those tracks which they have skipped within the time period.

So I think either the "Last Skipped" portion of this request should also be added, or this bug should be closed and the title changed to indicate only "Skipped Count" has been added. Otherwise, the entry for this bug in the 'change log' will misrepresent whether "Last Skipped" is available or not.

Ludek

2011-01-10 10:25

developer   ~0022265

OK, 'Last Skipped' is now tracked as 0007148