View Issue Details

IDProjectCategoryView StatusLast Update
0006243MediaMonkey (current)Playerpublic2010-10-12 01:57
ReporterLudek 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0006243: Some MP3 tracks show Length 0:00 although WMP shows the correct length
DescriptionI uploaded one mp3 track to our FTP ( /MMbugs/bug6243/03 - With You In Me [Silentstressor RMX].mp3 ).

If the track is played in MM then player shows e.g. 0:50/0:00
i.e. length of the track is reported incorrecly as 0:00

If the track is played in WMP then it correctly shows 3:53

TagsNo tags attached.
Fixed in build1301

Relationships

related to 0008718 closedjiri Some mp3 files show wrong track length 

Activities

michal

2010-01-13 08:44

developer   ~0019939

Last edited: 2010-01-13 10:22

The problem seems to be in the Xing header - StreamSize field, the indicated length is 793ms, but the expected length (from the file length) is 233s. I've tried MediaInfo software and it shows length 793ms too. WMP maybe ignores the StreamSize field and prefers expected length from the file length. MM prefers the minimum of DataLength (from StreamSize) and ExpectedDataLength (from file length).

Ludek

2010-01-13 11:27

developer   ~0019941

Last edited: 2010-01-13 11:28

Hmmm, I thought that it is something like this. I think that MM should be smart enough as WMP and iTunes and correctly guess that the DataLength (from StreamSize) value is incorrect by comparing the value with ExpectedDataLength (from file length).

i.e.
if (DataLength/ExpectedDataLength < 0.9) or (ExpectedDataLength/DataLength < 0.9) then
Length = ExpectedDataLength
else
Length = DataLength

jiri

2010-01-14 16:21

administrator   ~0019953

Ok, although it's a little questionable whether we should report the same length as WMP (the stream header is apparently corrupted), let's make the suggested fix. I'd just change the constant to something like 0.75, so that the other value is only used when the compared values are way too different.

michal

2010-01-14 16:54

developer   ~0019954

Fixed in build 1301. Now the track length is computed from file length, if the StreamSize is less then 75% of expected value.

peke

2010-10-12 01:57

developer   ~0020735

Verified 1315