View Issue Details

IDProjectCategoryView StatusLast Update
0006241MediaMonkey (current)DB/FileMonitorpublic2010-10-08 23:47
ReporterLudek 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0 
Summary0006241: 'Maintain Library' doesn't fix some DB inconsistencies
Description'Maintain Library' recreates and fixes inconsistencies and DB integerity issues, and cleans and optimizes database.

Nevertheless there are some inconsistencies like the one from ticket ATT-707700 that 'Maintain Library' doesn't fix. The problematic DB is attached on our FTP ( /MMeSupportTickets/BXG-495116 ), where the genre 'Sound Track' leaves in the main tree and cannot be deleted, because of inconsistence between Songs and GenresSongs table where corresponding Songs.ID for GenresSongs.IDSong doesn't exist.

I don't know how this inconsistency could happen, probably a script caused it, because there are DB triggers in MediaMonkey responsible for deletion of GenresSongs.IDSong when corresponding Songs entry is deleted.
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=7605&offset=10
Tagstodoc
Fixed in build1301

Relationships

related to 0006480 new Unused attributes aren't removed from Classifications 

Activities

Ludek

2010-01-10 17:18

developer   ~0019918

Fixed in build 1301.

peke

2010-10-08 23:47

developer   ~0020681

Verified 1314