View Issue Details

IDProjectCategoryView StatusLast Update
0006226MediaMonkey (current)Playlist / Searchpublic2010-10-17 23:43
Reporterstephen_platt 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2 
Target Version4.0Fixed in Version4.0 
Summary0006226: Character "ü" not found by "u" in search
Description1. Tag track as artist Hüsker Dü
2. Search for Husker Du, Husker, or Du
3. Track not found

Alternatively with artist Mel Tormé I can find the track by searching for Torme.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=1&t=45229&p=236819#p236819
TagsNo tags attached.
Fixed in build1301

Activities

Ludek

2009-12-18 17:01

developer   ~0019863

Last edited: 2009-12-18 17:02

Yes, these are extended ascii codes (128-255), see:
http://www.codesascii.com/

Problem is that there is a few varying 'extended' sets. But the most popular is one and I am about to use it in our internal map chars table in order to fix this issue.

Ludek

2009-12-18 18:06

developer   ~0019864

By further testing I found that it wasn't probably the extended ASCII problem as I previously thought, but rather mapping of 'ü' to 'ue' (probably because of german language). Fixed the mapping 'ü' to 'u' in build 1301.

Ludek

2009-12-21 15:43

developer   ~0019876

Last edited: 2009-12-21 16:35

Re-opened in order to change also current german conversion
'ä' -> 'ae'
to
'ä' -> 'a'

and to fix mapping for chars between 0x80 and 0xC0 (š,ce,ž):
http://www.tamasoft.co.jp/en/general-info/unicode.html

Note that SongTexts index table will need to be rebuilt:
Maintain Library -> Optimize Database (Complete)

Fixed in build 1301.

peke

2010-10-17 23:43

developer   ~0020814

Verified 1316