View Issue Details

IDProjectCategoryView StatusLast Update
0006203MediaMonkey (current)Playlist / Searchpublic2010-11-01 15:12
Reporteruser_chrisjj 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSXPOS Version-
Product Version 
Target VersionFixed in Version4.0 
Summary0006203: Track paste can go to wrong position
Description1 In tree, select Playlist and in tracklist, select track 1
2 Click CTRL+C, CTRL+V

Expected: track inserted before selection.
Observed: track inserted at end.

Reported at http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=42805
TagsNo tags attached.
Fixed in build1301

Relationships

has duplicate 0005479 closedLudek Cut/Paste of Track into Playlist: always pastes to end 
has duplicate 0000371 closedjiri Playlist: Paste into playlist doesn't paste to proper location in the playlist 
related to 0007549 closedLudek Song order when copying between playlists 

Activities

Ludek

2009-12-15 23:04

developer   ~0019850

Last edited: 2009-12-15 23:24

Fixed in build 1301.

Note that this was also issue for Now Playing list.

user_chrisjj

2009-12-16 00:36

updater   ~0019851

Last edited: 2010-10-16 01:13

View 2 revisions

Re the marking of this as duplicate, please note the substantial difference in the espected behaviour:

0005479 ... track inserted before selection.
0000371 ... rather than immediately following the selected track.

I see no mention of which one the fix adopted.

Ludek

2010-10-19 09:58

developer   ~0020858

Last edited: 2010-10-19 10:00

View 2 revisions

I marked them as duplicate, because the same fix was applied to all of them and the issues are in fact very similar. I don't think we need to have 3 issues in mantis for the almost same task with the same cause. This would be annoying for users to have all the 3 issues in the "What's new".
I think that the summary of this issue: "Track paste can go to wrong position" is general for all the 3 issues.

stephen_platt

2010-11-01 15:12

developer   ~0021091

verified build 1319 for now playing and playlists. the track is pasted directly after the selected track.