View Issue Details

IDProjectCategoryView StatusLast Update
0006185MediaMonkey (current)Otherpublic2009-11-16 16:23
Reporterrusty 
PriorityurgentSeverityminorReproducibilitysometimes
Status resolvedResolutionnot fixable 
Product Version3.1.2 
Target Version3.1.2Fixed in Version 
Summary0006185: Aeropeek fails when Auto-Tag from Web dialog is open (using MusicIP Tagger)
DescriptionIt's confirmed that Aeropeek fails if the user tries to switch tracks while the Music IP tagger is being run (See: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=44366 ).

I don't think that this needs to be resolved for 3.1.2, _unless_ the problem is likely to occur in many other scenarios. 3 different users are complaining about it, so if you can have a look at how often this issue is likely to occur, we can make a decision re. whether to create another update.
Steps To Reproduce1 Install MusicIP Tagger and restart MM
2 Play a playlist and verify that AeroPeek is working
3 Select a few tracks, right-click Auto-tag from web, choosing option of using the MusicIP Tagger as source
4 Put another application into focus
5 Hover over the MM application in the toolbar and wait for earopeek window to appear
6 Click 'next' in the Aeropeek window
--> Album Art window doesn't populate (and will not populate as long as the Auto-tag from Web window remains open).
TagsNo tags attached.
Fixed in build

Relationships

related to 0006183 closedpetr Auto-tag window comes to front on track change 

Activities

rusty

2009-11-16 16:23

administrator   ~0019733

This issue seems to be caused by specific scripts rather than the scripting framework generically. In the case of the MusicIP script, the MusicIP library anylyses a track, but MediaMonkey doesn't receive any WM_COMMAND message. Because a variety of Win7 features such as Aeropeek are dependent on this, they fail as well.