View Issue Details

IDProjectCategoryView StatusLast Update
0006137MediaMonkey (current)Install/Configpublic2010-10-10 02:16
Reporterrusty 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version3.1.2 
Target Version4.0Fixed in Version4.0 
Summary0006137: Empty HKCU\Software\Songs-DB key created by installer
DescriptionIs there a reason why HKCU\Software\Songs-DB is created at install?

Reported at:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=44111
TagsNo tags attached.
Fixed in build1301

Activities

jiri

2009-11-04 22:02

administrator   ~0019551

Last edited: 2009-11-04 22:03

Fixed in build 1285.
 - I haven't tested the updated installer, but all references to Songs-DB have been removed.

stephen_platt

2009-11-05 05:35

developer   ~0019564

not resolved with 1285:
1. Clear the key manually via regedit
2. Install MM build 1285
3. Don't launch MM, check registry
4. Songs-DB entry at HKEY_CURRENT_USER\Software\Songs-DB

jiri

2009-11-05 13:45

administrator   ~0019566

I'm not sure why does it happen during install, but I found out that there are still some plug-ins using this registry key. Since it isn't any real issue for users, I deferred the fix to MM 4.0, in order to avoid regressions.

jiri

2009-11-26 16:21

administrator   ~0019779

Ludek, please review the remaining plug-ins, so that the key isn't used.

Ludek

2009-11-26 19:43

developer   ~0019781

Yes, installer indeed has written the key and also some plugins like out_MMDS.dll.

Fixed in build 1301.

peke

2010-10-10 02:16

developer   ~0020708

Verified 1315