View Issue Details

IDProjectCategoryView StatusLast Update
0006108MediaMonkey (current)Hotkeyspublic2009-11-04 15:49
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1.2 
Target Version3.1.2Fixed in Version3.1.2 
Summary0006108: MultiMedia Play/Pause button fails when application is minimized
DescriptionOn a clean install, using the Microsoft Comfort 2000 keyboard (without any intellitype drivers), the following behavior is observed:
-When MM, Notepad, or Windows explorer are in focus: Play/Pause works correctly
-When Firefox, Gain, or EditPad are in focus: Play/Pause button causes either of the following to occur (seems to alternate randomly between these behaviors):
 - Aeropeek always show the 'Pause' indicator, despite the fact that MM is playing, and each press causes a momentary pause
 - Aeropeek always shows the 'Play' indicator, despite the fact that MM is paused, and each press causes a moment of playback

I suspect that the root of the problem is as Peke described here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43492#p227532

But that doesn't completely explain the strange Aeropeek behavior...?!

Even more strange, though, is that when I go to the hotkeys configuration panel, and edit the hotkey for Playback: Play/Pause to use the Media Play/Pause button (which appears to be _exactly_ what the default config is), then the behavior changes to:
-When MM, Gaim, EditPad or Firefox are in focus: Play/Pause works correctly!
-When Notepad or Windows Explorer are in focus: Play/Pause button has no effect!
Additional InformationNote:
-For Windows Media Player, Winamp, and iTunes, Play/Pause works in all cases except when Windows Explorer is in focus
-iTunes doesn't seem to have Global hotkeys support
-user indicated that problems were only introduced once Aeropeek features were added to MM: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43492
TagsNo tags attached.
Fixed in build1283

Activities

2009-10-29 18:16

 

multmedia_keys_issue_6108.LOG (165,855 bytes)

2009-10-29 22:30

 

multimedia_key_config_change.LOG (53,119 bytes)

jiri

2009-10-30 14:28

administrator   ~0019417

Fixed in build 1282.

peke

2009-11-01 00:42

developer   ~0019435

Last edited: 2009-11-01 00:44

Still Not Working in 1282, Play/Pause is recognized twice in MM when Global is Set.

Pic of Global settings is uploaded to FTP

Tested on Logitech G15 and Internet Navigator, Turbo Vision 9001

peke

2009-11-01 11:30

developer   ~0019445

Restart of PC, clean reinstall of MM fixed the problem today.

peke

2009-11-01 11:32

developer   ~0019447

Verified 1282

There must be an glitch on my PC. Can't replicate anymore.

jiri

2009-11-01 14:42

administrator   ~0019448

As reported in http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43946 , there is a regression causing MM freeze in some cases.

jiri

2009-11-01 14:44

administrator   ~0019449

Fixed in build 1283.

stephen_platt

2009-11-03 05:01

developer   ~0019509

verified 1283