View Issue Details

IDProjectCategoryView StatusLast Update
0006072MediaMonkey (current)Synchronizationpublic2010-08-02 14:10
Reportermichal 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.2 
Target Version3.2.2Fixed in Version3.1.2 
Summary0006072: Lyrics missing in the iPod sometimes (tested on Nano 4G)
DescriptionThis sequence leads to the missing lyrics for the track in the iPod:
1) Copy a track with lyrics into the iPod.
2) Play the iPod track in MediaMonkey ("Synchronizing" screen is displayed in the iPod for a while during playing)
3) Stop playing the track, eject the iPod
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=6617
Tagstodoc
Fixed in build1277

Relationships

has duplicate 0006087 closedjiri Missing lyrics in iPod in certain specific cases 
related to 0006156 closedLudek iPod Synchronization: Lyrics sometimes truncated when updating already existing track in iPod 

Activities

rusty

2009-10-21 16:37

administrator   ~0019278

The issue isn't that critical, but setting as 'urgent' for technical review by Jiri since this could be symptomatic of other problems.

jiri

2009-10-22 09:55

administrator   ~0019282

Fixed in build 1277.

michal

2009-10-23 06:17

developer   ~0019307

Displaying the iPod track properties in MediaMonkey and pressing OK causes iPod showing "Lyrics detected, but unable to retrieve" instead of lyrics for this track.

jiri

2009-10-23 07:03

administrator   ~0019308

This is a problem MM can't fix, since it happens when iPod doesn't understand that particular ID3v2 tag. It often helps to remove album art from the tag.

jiri

2009-10-23 08:22

administrator   ~0019309

Last edited: 2009-10-23 08:23

Further discussion over IM showed that although the playback problem was solved, editing properties really still causes this problem. I decided to leave it this way, since the problem only affects old iPod models (Nano 4G, but not 5G) and doesn't affect iPhone/Touch at all, since all these models have Lyrics stored in the internal DB. There isn't an easy fix without side effects for the older models and so it seems to make sense to leave it this way.

stephen_platt

2009-10-25 18:42

developer   ~0019341

verified 1277

stephen_platt

2010-01-11 23:19

developer   ~0019924

A few users in the forum are having issues with older iPods which show lyrics (iPod photo, iPod video) as well as the newer iPod classic.

Steps to reproduce are:
-Sync multiple playlists via auto-sync. Disconnect the iPod. Tracks will now show their lyrics.
-Perform another auto-sync (same settings). Check lyrics of the same file and lyrics have now disappeared.

I can't verify this because I don't have an iPod that displays lyrics (only iPhone). For what it's worth, I can't reproduce the issue with the iPhone.

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=29464&st=0&sk=t&sd=a#p150005

michal

2010-01-12 10:52

developer   ~0019927

Last edited: 2010-01-12 10:54

A can confirm this behaviour, I have iPod Nano 4G. My steps to reproduce:
1) create playlist with songs with lyrics, select this playlist for auto-sync, make auto-sync and disconnect iPod. Tracks show their lyrics.
2) connect iPod, make auto-sync again, disconnect. Lyrics are not showing.

But I've found another thing out. Now (after step 2) when I try iTunes - Get Info on the song with lyrics (devices-iPod node), the lyrics are there, I push OK. After that, it seems the lyrics of this song do not disappear, even when I make auto-sync in MM several times.

Ludek

2010-06-28 16:13

developer   ~0020305

I cannot reproduce it with my iPod Nano 2G.

jiri

2010-08-02 10:49

administrator   ~0020414

More testing with Michal revealed that the problem was in the fact that iTunes was automatically starting as soon as the iPod was connected. There doesn't seem to be anything we can do about it, users must disable iTunes start-up. I think that we already have this covered in the KB, at least in case of Album Art problems, but maybe this might be added as well.

rusty

2010-08-02 14:10

administrator   ~0020415

Noted at: http://www.mediamonkey.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=133