View Issue Details

IDProjectCategoryView StatusLast Update
0006007MediaMonkey (current)Framework: Scripts/Extensionspublic2009-10-16 13:02
ReporterLudek 
PriorityhighSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1.2Fixed in Version3.1.2 
Summary0006007: Possible COM error during Windows shutdown
DescriptionOne user complained here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43076&p=224999#p224999

That the COM error is displayed before his script is even able to handle the OnShutDown event.

Although we haven't been able to repro this we can use suggestion from here:
http://blog.delphi-jedi.net/2008/07/01/com-server-tells-you-sth-about-opened-client-connections/
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43076&p=224999#p224999
TagsNo tags attached.
Fixed in build1272

Relationships

related to 0003879 closedpeke Automatization Server is revoked too early 

Activities

Ludek

2009-10-03 15:43

developer   ~0019050

Fixed in 1271.

Ludek

2009-10-06 21:07

developer   ~0019088

Re-opened, because it hasn't been fully resolved.

Ludek

2009-10-06 21:37

developer   ~0019089

Tested with the MonkeyFlow script and solution is to set up
ComServer.UIInteractive to false

This can be done via new GET/LET property I have added:
ISDBApplication.ComServerUIActive

Added in build 1272.

Ludek

2009-10-06 21:44

developer   ~0019090

Last edited: 2009-10-06 22:02

Documented here:
http://www.mediamonkey.com/wiki/index.php/SDBApplication
and here:
http://www.mediamonkey.com/wiki/index.php/ISDBApplication::ComServerUIActive

Ludek

2009-10-06 22:26

developer   ~0019091

Last edited: 2009-10-06 22:26

Finally I decided to set the property to FALSE by default in order to prevent the annoying messages, because it seems to be safe, see:
http://www.blong.com/Conferences/DCon2002/Speech/SAPI4HighLevel/SAPI4.htm

Fixed in build 1272.

peke

2009-10-16 13:02

developer   ~0019207

Verified 1274