View Issue Details

IDProjectCategoryView StatusLast Update
0005981MediaMonkey (current)Synchronizationpublic2016-11-17 22:43
ReporterLudek 
PriorityurgentSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.1 
Target Version4.1Fixed in Version4.0.7 
Summary0005981: Tracks purchased directly to iPhone don't show up in MM interface
DescriptionIf you purchase a track from iTunes Store directly to iPhone then the tracks show up in iPhone, iTunes, but don't show up in MM interface. What is even worse that upon auto-sync they can disappear from iPhone.

I tested this on iPhone Software v2.2.1 and now I am testing on v3.1

Additional issue is with podcasts downloaded directly to iPhone, they aren't shown in MM interface.

The second important note is that downloaded podcasts and purchased music aren't stored in 'iTunes_Control/Music' folder, but in 'Podcasts' and 'Purchases' folder until iTunes move it to 'iTunes_Control/Music' by using the iTunes' Transfer Purchases feature.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=43265
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=18033&departmentid=2&ticketstatusid=2
TagsNo tags attached.
Fixed in build1503

Relationships

related to 0008076 assignedLudek iOS device browsing: fails to show Audible (extended) tracks 
related to 0009752 closedLudek No easy way to transfer purchases from iPhone 
related to 0013664 resolvedLudek MediaMonkey fails to read iPhone purchases (regression) 

Activities

Ludek

2009-09-25 10:14

developer   ~0018989

Last edited: 2009-09-25 10:17

Tested again on 3.1 iPhone software today and problems are:

If you purachase a track directly in iPhone it is firstly stored to the folder 'Purchases' instead of 'iTunes_Control/Music'. Same thing for podcasts, they are firstly stored to 'Podcasts' folder instead of 'iTunes_Control/Music'.

BUT, if you connect iPhone to iTunes, right-click the iPhone and select 'Transfer Purchases' then iTunes moves the files from 'Purchases' and 'Podcasts' folders to 'Music' folder on the iPhone and MM see the tracks now!

If you don't use the 'Transfer Purchases' command in iTunes then MM don't see the tracks, because MM seems to read only the 'Music' folder.

And there is a way to disappear the song from iPhone:
1. Buy a track to iPhone
2. Open MM, MM don't see it as described above
3. Open iTunes and Transfer Purchases, iTunes moves it to 'Music'
4. Auto-Sync in MM
-> track is lost from iPhone's DB, because iTunes moved it into 'Music' meanwhile, but MM didn't re-read the iPhone DB.

Jiri, I uploaded my iPhones DB and 'Purchases' folder on our FTP, it is file 'iPhone_root.zip'. By extracting you can see the directory structure, as you can see the 'Purchases' and 'Podcasts' dirs are directly in the root whereas 'Music' folder is sub to 'iTunes_Control' same as 'iTunes' folder where is my DB.

jiri

2009-11-27 14:21

administrator   ~0019791

Fixed in build 1300.
 - Downloaded Podcasts are now properly read and handled, including Album art.
 - All types of Purchases (tracks, movies, tv-shows, ...) are properly read and handled, including Album art.

The only remaining feature I can imagine is something like 'Transfer Purchases' in iTunes. However, since it's very iPhone special command only and probably isn't too important, it doesn't seem to make much sense to implement. Note, that user can do it himself, now that these tracks are accessible using MM interface, they can be easily played, copied or deleted using MM.

stephen_platt

2011-05-15 23:39

developer   ~0025281

I just downloaded a free track from iTunes directly to my iPhone 4 (fw 4.3.2) via WiFi but after connecting via USB to MM I could not find the downloaded track.

Ludek

2012-09-25 12:45

developer   ~0032169

Fixed in build 4.0.7.1503

stephen_platt

2012-09-25 23:26

developer   ~0032181

verified build 1503