View Issue Details

IDProjectCategoryView StatusLast Update
0005970MediaMonkey (current)Main Panel/Toolbars/Menuspublic2010-10-18 14:07
Reporterstephen_platt 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1.2 
Target VersionFixed in Version4.0 
Summary0005970: "Focus tracklist on currently playing item" does not work in AA + details view
Description1. Assign a hotkey to Focus tracklist on currently playing item
2. Play any track
3. Switch to Album art with details view
4. Click on any track which isn't playing
5. Use hotkey which was assigned earlier
6. Nothing happens
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=41281&p=214044&hilit=now+playing+album+art+view#p214044
TagsNo tags attached.
Fixed in build1316

Relationships

child of 0007101 resolvedpetr SDB.MainTracksWindow.Focused = xx is not working always correctly in Album Art with Details 

Activities

petr

2009-09-22 23:21

developer   ~0018967

Fixed in 1300

zvezdan

2010-09-21 07:04

updater   ~0020558

I am going to report two similar things within this issue since they are related.

- Scripting API SDB.MainTracksWindow.Focused = xx is not working either if Album Art with details view mode is selected.

- Switching to the Album Art view mode (without details) doesn't display the album with the selected track, just gives it the keyboard focus. Here are steps to reproduce:
1. select Details view mode;
2. select some track in the main tracklist;
3. switch to Album Art view mode -> the album with the selected track is not displayed;
4. press the down key on the keyboard and after that press the up key on the keyboard -> the album is now displayed.

The Album Art with details view mode doesn't have this problem, e.g.:
1. select Details view mode;
2. select some track in the main tracklist;
3. switch to Album Art with details view mode -> the album with the selected track is displayed correctly.

peke

2010-10-11 01:15

developer   ~0020717

Confirmed both issues, Maybe merge in 3.2.3 could useful.

petr

2010-10-12 20:12

developer   ~0020738

Fixed in 1316

stephen_platt

2010-10-18 14:06

developer   ~0020828

verified 1316