View Issue Details

IDProjectCategoryView StatusLast Update
0005809MediaMonkey (current)Properties/Auto-Toolspublic2009-10-16 01:07
Reporterjiri 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version3.1.1 
Target VersionFixed in Version3.1.2 
Summary0005809: Tagging of large album art on OGG tracks can crash
DescriptionAs reported in http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=5021, tagging of OGG files can fail in case of large album art. Users reported corrupted tracks, in my case it only resulted in failed tagging.
TagsNo tags attached.
Fixed in build1265

Activities

jiri

2009-06-21 11:19

administrator   ~0018458

While debugging, I found out that the problem is in a call to vorbis_comment_add_tag() function of Vorbis library.

We should:
1. Update ogg_static.lib and vorbis_static.lib libraries to the latest version from http://xiph.org/downloads/ (there are both available in newer version).
2. In case it doesn't help, further debug.

jiri

2009-06-21 16:04

administrator   ~0018459

Fixed in build 1300.

jiri

2009-06-21 16:18

administrator   ~0018460

Merged into build 1257.

peke

2009-10-16 01:07

developer   ~0019186

Verified 1273