View Issue Details

IDProjectCategoryView StatusLast Update
0005668MediaMonkey (current)Main Panel/Toolbars/Menuspublic2009-06-05 12:14
ReporterMizery_Made Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1Fixed in Version3.1 
Summary0005668: Home key can jump to End in some cases
DescriptionUser fourteen has reported a case of odd behavior in the forum that results in the Home key on the keyboard actually jumping to the End.

Steps to reproduce this behavior are contained in the thread it was reported it. It seems to only occur if you use the Hotkey to go to the next track's properties, while working find if you click the arrow on the properties window.

I have reproduced several times following his posted workflow and the results are always the same. The Home key after these steps result in the curser going to the end of the string.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=39811

Steps to replicate
0- trying to add the artist Foo Bar to some tracks
1- get "Foo Bar; " (without the quotes) to the clipboard, e.g. by using Notepad and copy the string "Foo Bar; "
2- right click the first track of the album and select "Properties"
3- position the caret at the first position in the Artist field
4- type Ctrl-V to paste in "Foo Bar; "
5- use Alt-right arrow to get to next track
6- notice how the caret is not in the first position in the Artist field
7- use Home key to position the caret in the first position

Expected behavior: caret moves to first position in Artist field
Observed behavior: caret moves to last position
TagsNo tags attached.
Fixed in build1249

Relationships

parent of 0005895 closedLudek Properties Dialog: Foreign characters cannot be entered via ALT + Numeric keys 

Activities

2009-05-25 11:09

 

1.JPG (56,440 bytes)   
1.JPG (56,440 bytes)   

Ludek

2009-05-25 11:14

developer   ~0018007

Last edited: 2009-05-25 11:55

I see, user seems to refer to the situation when pressing 'Alt + Right' causes the auto-complete menu to open and therefore there is the problem, see the screenshot attached here to the issue 5668:
i.e. http://www.ventismedia.com/mantis/file_download.php?file_id=408&type=bug

So easier steps to repro is just hitting Alt key that causes the auto-complete to pop-up.

This seems to be problem on skinned version only.

Ludek

2009-05-25 14:29

developer   ~0018008

Fixed in build 1249.

peke

2009-06-05 12:14

developer   ~0018172

Verified 1250