View Issue Details

IDProjectCategoryView StatusLast Update
0005631MediaMonkey (current)DB/FileMonitorpublic2010-10-26 12:32
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version4.0 
Summary0005631: It is not clear what "Clear Library" is going to do
DescriptionSome users claimed that "Clear Library" deletes also auto-playlists and podcasts. Perhaps the option could be better renamed to 'Clear database' (as that is the function it's really carrying out).

Actually it might be nice if 'Clear database' would contain an options window like Maintain Library where one could choose what should be cleared.

In addition 'clear database' suggestion, it would however be nice to have a true 'clear library' too.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=37772
TagsNo tags attached.
Fixed in build1300

Relationships

related to 0005836 closedLudek Clear Library loses Auto-sync [X] Playlists and [X] All Music 
related to 0005946 closedLudek SEVERE Discrep in Clear Library behaviour 
parent of 0008834 closedLudek Clear Library dialog mentions Filters instead of Collections 
related to 0006039 closedLudek 'Clear Library' action should not delete devices 
related to 0006535 new Delete MM.DB dialog in case of corruption 
related to 0008835 assignedpetr Clear Library fails for very large databases 

Activities

Ludek

2009-09-18 10:22

developer   ~0018905

Last edited: 2009-09-18 10:48

Rusty, I closed issues 0005836 and 0005946 because they are in fact parts of this issue. The issues only contain these two links:
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=42708#p222224
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=40966&start=0&st=0&sk=t&sd=a
that are related to this issue.

Please review this issue, I also think that we should rename "Clear Library" to "Clear Database".

@Chris
If you have any suggestions then please don't open the two issues, but keep your suggestions here in the notes to this issue so that it is tracked in one place.
Thank you.

rusty

2009-09-18 17:49

administrator   ~0018919

So to summarize the problem: Clear Library implies only clearing the Library and not any playlists or configuration data (such as filters, or devices).

2 Possible approaches:
1) Short term: 'Clear Database...' would be a start, but wouldn't fully solve this because most users have no idea what is in the database. So, we'd have explain exactly what is being deleted e.g. 'This will delete all Library data, Playlists, Filters, and configured Devices). Are you sure you want to proceed?

2) Medium term: Wouldn't it make sense for Device configurations to not be stored within the DB?

Note: I don't think it's necessary to give the ability to delete any of these items individually, since that can already be accomplished via the regular UI.

stephen_platt

2009-09-18 18:02

developer   ~0018921

Quick note: The MM help file explains that clear library will remove all database track info and playlists. The only thing missing from that documentation is that device configs will also be removed.

Mizery_Made

2009-09-19 05:12

updater   ~0018931

It doesn't specify that Filters would be deleted as well, in the help file. One might see the relation between Filters and Playlists and come to the conclusion that they would also be deleted, but it doesn't specifically specify.

stephen_platt

2009-09-19 13:06

developer   ~0018934

I think most would see filters as a part of the library, since filters are displayed as:
Library (filter name)

in the library node.

Ludek

2009-09-22 13:12

developer   ~0018960

Ok, I selected item 1) and resolved in build 1300 this way.

Menu caption changed from
'Clear Library...' -> 'Clear Database...'

Confirmation text changed from
'Are you sure you want to remove all data from the Library database (this will not delete any of your files)?'
->
'Are you sure you want to remove all data from the Library database? This will delete all Library data, Playlists, Filters and configured Devices, but this will not delete any of your files.'

Fixed in build 1300.

Ludek

2009-10-15 19:57

developer   ~0019156

Last edited: 2009-10-15 20:17

Re-opened, because we are going to remove deletion of devices from "Clear Database" actions (0006039)

rusty

2009-10-15 20:07

administrator   ~0019157

We'll need to make a small change to the text due to a fix that causes 'Clear DB.' to not impact device settings. Updated string:

Are you sure you want to remove all data from the Library database? This will delete all Library data, Playlists, and Filters but this will not delete any of your files.

Ludek

2009-10-15 20:22

developer   ~0019160

Fixed in build 1300.

stephen_platt

2010-10-26 12:32

developer   ~0020989

verified 1318