View Issue Details

IDProjectCategoryView StatusLast Update
0005422MediaMonkey (current)Burning / Disc Handlingpublic2010-10-07 21:08
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version4.0 
Summary0005422: Cannot terminate burn that's in progress
DescriptionIf the user attempts to terminate a burn that is in progress, nothing happens (the burn continues).
Additional InformationReported at: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=37786
TagsNo tags attached.
Fixed in build1300

Activities

jiri

2009-03-27 11:12

administrator   ~0017209

I'm not sure:
 1. whether it's possible using Primo SDK, but probably yes. It should definitely work well in case MM works on auto-conversion, i.e. before actual burning.
 2. I don't know whether we have any string for a dialog that would warn user that the disc being burned would be damaged by termination of burning. In case we don't, it should be defered past 3.1.

Ludek

2009-03-30 10:22

developer   ~0017232

Last edited: 2009-03-30 10:23

Yes, it is possible to terminate burn using Primo SDK for both audio and data CD burning.

Now, it works if the MM works on auto-conversion (Data CD) or preparation of tracks for audio CD burning. It just has never worked when the writing to the disc starts because as Jiri indicated it would damage the disc.

So now the problem is only in the availability of a warning string.

Rusty, what string you wish to use as the warning?

rusty

2009-03-30 14:04

administrator   ~0017233

So in cases where termination is initiated during the actual disc burning, the following warning could appear:

Warning:
Terminating a Disc burn will create an unreadable disc. Are you sure you want to proceed?

[[Yes]] [No]

Ludek

2009-06-19 11:15

developer   ~0018453

Fixed in build 1300.

peke

2010-10-07 21:08

developer   ~0020657

Verified 1314