View Issue Details

IDProjectCategoryView StatusLast Update
0005252MediaMonkey (current)Framework: Scripts/Extensionspublic2009-05-07 21:23
ReporterBex 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1Fixed in Version3.1 
Summary0005252: Executing mmip files sometimes opens an additional MM
DescriptionIt seems to only happen when you execute the file from within various download windows, etc.
If executing it from the desktop or explorer then it works correct. I believe this has always been the case but I couldn't find any bug report about it. It's annoying, especially for new users. Questions are frequently raised regarding this behavior in the forum.
TagsNo tags attached.
Fixed in build1243

Relationships

related to 0005534 closedpeke Installation of extensions fails in some cases even if MM is running as Admin 

Activities

rusty

2009-01-27 05:05

administrator   ~0016400

Bex: Resolving only because there's insufficient information to reproduce this (I've tested with numerous .mmip files but have never observed this).

Do you have a set of steps to reproduce this? Is it specific to certain .mmip files?

Teknojunky

2009-01-27 19:34

updater   ~0016412

Last edited: 2009-01-27 19:34

if you have enabled multiple instances, double clicking a MMIP file *used* to open a new MM instead of using an exising instance.

This was in 3.0, I have not tried with any newer.

Even if multiple instance is enabled, it is my opinion that mmip shold use existing instance first, before opening new one.

Bex

2009-01-27 20:38

updater   ~0016414

Last edited: 2009-01-27 20:39

Yeah, the key here is to uncheck "Allow Just One Instance of MM".
If unchecked then the behavior described in first post happens. If checked then it works as it should.

jiri

2009-01-28 09:08

administrator   ~0016432

Well, but that's what 'Allow Just One Instance of MM' is there for. I wonder whether we shouldn't hide this option from Options dialog and only leave it in ini file as an 'undocumented' feature for advanced users?

rusty

2009-01-28 13:38

administrator   ~0016438

I think the point is that most users expect that if multiple instances are allowed that:
-double-clicking an .mmip file would use an existing instance
-double-clicking a track would open a new instance
-Explore Context menu - play next/play last in MediaMonkey would use an existing instance

Is that possible?

Bex

2009-01-28 14:19

updater   ~0016439

Yes, the issue here is that if you have unchecked 'Allow Just One Instance of MM' then only mmip-files executed from the desktop/explorer works fine, while mmip-files executed from within a download window and similar opens up an extra instance of MM.

Teknojunky

2009-01-28 14:35

updater   ~0016440

as far as I can remember when I last used 'allow multiple instances', mmips always opened new instances (desktop or download).

jiri

2009-01-28 15:34

administrator   ~0016441

The problem is when to decide to use/not use the previous instance. There are various scenarios of parameters passed over command-line (which can also be initiated by user, or by clicking the file in Explorer) or using IDropTarget COM interface. As far as I know, this isn't even consistent across verious Win versions, diffect methods are used in different scenarios.

So, although generally speaking we could try to change something here, I wouldn't do so for 3.1. And, for future versions, I would possibly prefer to get rid of that option completely.

rusty

2009-05-06 15:44

administrator   ~0017701

This was fixed in 1243 in the course of fixing 0005534.

peke

2009-05-07 21:23

developer   ~0017734

Verified using 1244 and Win 7 x64