View Issue Details

IDProjectCategoryView StatusLast Update
0005227MediaMonkey (current)Help / Docs / Localizationpublic2011-07-14 22:51
Reporterrusty Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Fixed in Version4.0 
Summary0005227: Review string capitalization
DescriptionIssue raised by UI (dutch translator):

[quote]Why are there capitals all over the place, where they don't belong?[/quote]

I think you make a good point. We've tried to use the following conventions, but I don't think we've been consistent enough:
-Capitalize track attributes: e.g. Genre
-Capitalize menu commands: e.g. Advanced Tag Management
-Capitalize some keywords with specific meaning in MM: e.g. Tracks, Album Art
Most other items do not need to be capitalized (other than the first word in a phrase)

I don't want to go through the strings right now, as this would force translators to do another round of translation, but I will enter a bug to review this top to bottom for the next release.
TagsNo tags attached.
Fixed in build1351

Relationships

parent of 0008405 assignedrusty Options > OS integration has wrong capitalization 
related to 0007413 closedpeke Localization/string errors in 4.0.0.1349 
Not all the children of this issue are yet resolved or closed.

Activities

rusty

2011-02-14 23:41

administrator   ~0023092

Much of this has been fixed in 4.0 (i.e. whenever strings are changed, capitalization was reviewed).

lowlander

2011-03-01 16:11

developer   ~0023465

Library > Files to Edit Unorganized files/unclassified files doesn't have Files capitalized whereas all other nodes do have additional words capitalized.

rusty

2011-03-01 16:20

administrator   ~0023468

Last edited: 2011-03-01 17:30

View 2 revisions

Ludek, the following text (re. Files to edit nodes) should be changed:

1) Unorganized files
-->
Unorganized Files

2) Unclassified files
-->
Unclassified Files

3) All instances of 'audio CD' should be replaced with 'Audio CD' for consistency.

4) Capitalization is used inconsistently when referring to file types. The rule of thumb suggested by Gege, should be that .m3u/.xspf (lower case) should be used when referring to the extension, and M3U/XSPF (upper case) should be used when referring to the file format itself. A good reference of how they should be used appears in Tools > Options > OS integration panel. Areas for improvement:

a) Advanced Search > Add search criteria > File type property: extensions should all be lowercase

b) Inconsistent use of .m3u vs M3U / .xspf vs XSPF in strings:
i) Show .m3u playlists in My Computer nodes
--> Show M3U playlists in My Computer nodes

ii) Create .m3u playlists to more easily navigate the tracks on a device
--> Create M3U playlists to more easily navigate the tracks on a device

iii) Burn .m3u Playlists
--> Burn M3U Playlists

iv) Burn .m3u
--> Burn M3U

v) Use extended .m3u
--> Use extended M3U

vi) Generate .m3u Playlists for:
--> Generate M3U Playlists for:

vii) Burn .m3u Playlists to:
--> Burn M3U Playlists to:

viii) Save selected track(s) to .m3u playlist
--> Save selected track(s) to M3U playlist

ix) New .m3u Playlist
--> New M3U Playlist

x) Save selected track(s) to .m3u/.xspf playlist
--> Save selected track(s) to M3U/XSPF playlist

xi) Choose portable device folder to store .m3u playlists.
--> Choose portable device folder to store M3U playlists.

xii) New playlist.m3u [this string appears to be malformatted!!]
--> New playlist.M3U

xiii) Create new m3u playlist
--> Create new M3U playlist

xiv) Enter name of the new m3u playlist:
--> Enter name of the new M3U playlist:

xv) Playlists (m3u, xspf) then Tags
--> Playlists (M3U, XSPF) then Tags

xvi) .m&3u/.xspf playlist ?? Not sure where this appears / whether it should be changed ??

Ludek

2011-03-01 20:37

developer   ~0023476

Fixed in build 1351.

xvi) it appears in
Send to -> .m&3u/.xspf playlist
so I changed it to
Send to -> M&3U/XSPF playlist

rusty

2011-03-02 18:13

administrator   ~0023497

Gege pointed out that item xii) is probably correctly formatted as it was originally i.e. New playlist.m3u

Can you confirm?

Ludek

2011-03-02 22:15

developer   ~0023509

Yes, it was correctly formatted and is used as pre-defined name when new m3u playlist is going to be created. Nevertheless I changed it to "New Playlist" only, because the m3u extension is auto-added anyhow.

peke

2011-07-14 22:51

developer   ~0026833

Rechecked and closing.