View Issue Details

IDProjectCategoryView StatusLast Update
0005194MediaMonkey (current)Main Panel/Toolbars/Menuspublic2011-02-07 04:32
Reporterstephen_platt 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version4.0 
Summary0005194: MM Unsynchronized Tags fails to show the difference highlight for the comment and composer field
Description1. Take any mp3 file.
2. Select it, go to Tools | Advanced tag management | Clear ID3v1 and ID3v2 tags
3. Open unsynchronized tags node
4. Observe file with all columns open.
5. Both Composer and Comment fields are not highlighted
TagsNo tags attached.
Fixed in build1344

Relationships

duplicate of 0005727 closedLudek Files to Edit > Unsynchronized tracks doesn't report some unsynced tracks (for non ID3v1 fields) 

Activities

2009-01-14 19:22

 

unsynced tags.png (16,652 bytes)
unsynced tags.png (16,652 bytes)

jiri

2009-01-14 22:07

administrator   ~0016209

Last edited: 2009-01-20 20:47

This is currently as designed, since we use ID3v1 fields only for this function.

[Edit: it works for ID3v2, I just meant that it doesn't work for any of the advanced fields, just for Artist, Album, Title, Genre, Year and Comment.]

However, this seems to be quite outdated design, it's probably time to re-design it. Almost nobody uses ID3v2 fields exclusively and so we should include all, or almost all, fields in this function. Probably not for 3.1, but it should be changed then.

user_chrisjj

2009-07-09 01:22

updater   ~0018560

Jiri, you wrote: "it doesn't work for any of the advanced fields, just for Artist, Album, Title, Genre, Year and Comment" yet this report includes failure on Comment. Please clarify.

stephen_platt

2011-02-07 04:32

developer   ~0022869

fixed with resolution of 0005727

stephen_platt

2011-02-07 04:32

developer   ~0022870

verified 1346