View Issue Details

IDProjectCategoryView StatusLast Update
0005097MediaMonkey (current)Help / Docs / Localizationpublic2009-02-21 16:08
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version3.1 
Summary0005097: Localization string problems in 3.1
DescriptionReported by REIKA

a) The following items exist in 'default.po' or 'DB.po', but they are not displayed in translated language.
 
(View > Toolbars > Configure > Player)
[Volume Down] , [Volume Up]
 
(Tools > Options > Filters&Views)
(Tools > Options > Hotkeys > Action:)
(Tools > Options > Auto-DJ / Now Playing > Add tracks from:)
(Tools > Options > Auto-Organaize > Add Auto-Organize rule... > Filters)
(Right click Library node > Filters)
[Podcasts] , [Audiobooks] , [General Music] , [Available Tracks]
 
(Tools > Options > Hotkeys > Action:)
[Statistics] , [Track List (HTML)] , [Track List (XML)] , [Track List (CSV)] ,
[Track List (Excel)] , [Auto-increment Track #s...] , [Swap Artist and Title] ,
[Case Checker...] , [Export all Playlists...] , [Export subscribed Podcasts...]

b) The following item is displayed wrong in Japanese translation.
 
 (View > Toolbars > Configure)
[Standard]
Please see 'tb_config.jpg' .

c) The following items were missing (REIKA added these himself to Japanese "DB.po"--I expect he'll have to undo this once we fix this).
 
[Export subscribed Podcasts...]
[Exports subscribed Podcasts to .opml file]
[Very fast]
TagsNo tags attached.
Fixed in build1217

Relationships

related to 0005340 resolvedjiri Untranslated strings 

Activities

2008-12-29 16:26

 

tb_config.jpg (90,393 bytes)
tb_config.jpg (90,393 bytes)

petr

2009-01-09 13:54

developer   ~0016105

With latest translation files from Reiko it looks ok on my Virtual Japanese XP.

rusty

2009-01-11 06:10

administrator   ~0016129

Last edited: 2009-01-11 06:13

Tested in 1210 with Spanish translation and found that the following are not translated:

1) (View > Toolbars > Configure > Player)
a)[Volume Down]
b)[Volume Up]
 
2) (Tools > Options > Hotkeys > Action:)
a) [Statistics]
b) [Track List (HTML)]
c) [Track List (XML)]
d) [Track List (CSV)] ,
e) [Track List (Excel)]
f) [Auto-increment Track #s...]
g) [Swap Artist and Title] ,
h) [Case Checker...]
i) [Export all Playlists...]
j) [Export subscribed Podcasts...]
k) The filters all display as e.g.: Filtrar: Audiobooks . I'm not sure if this is because I first ran MM in English, or because the list isn't being constructed based on the actual filter names.

3) Tools > Scripts
a) [Export subscribed Podcasts...]
b) Tooltip: [Exports subscribed Podcasts to .opml file]

Note: re. REIKA's original item b) I cannot reproduce the problem--at least not in Spanish.

petr

2009-01-11 14:15

developer   ~0016141

Last edited: 2009-01-11 14:16

Fixed in 1211.
Re Filters : Filters names are generated based on selected language when first run (actually when MM creates database).
Item 3) added these two texts into DB.po, so translation will be needed.

rusty

2009-01-13 18:20

administrator   ~0016185

More issues:

4) The following items exist in 'default.po' or 'DB.po', but they are not displayed in translated language.

a) WMA encode options > Channels dropdown
[Stereo] , [Mono]

b) WMA and AAC encode setting:
[Variable bitrate (VBR)], [Average bitrate (ABR)]
(also see item 5c below)


5) The following items don't have localization strings:

a) Tools > Options > Library: [Remove unused Attributes (Artist, Album, Composer, ...)]

b) Advanced Search > Status:
[has Album Art]
[hasn't Album Art] (note: should be changed to 'has no album art'

c) WMA encode settings. Note: for both of these, MM already has a string for Constant Bitrate (see MP3 encoder settings). Would it be better to just use the existing strings, and add '1-pass' and '2-pass' strings?
[Constant bitrate (CBR) 1-pass]
[Constant bitrate (CBR) 2-pass]

d) AAC encoder settings:
[Mid/Side stereo]

e) View > Toolbars > Configure > Clipboard
[Add to Clipboard]...... (note: I'm not sure that this entry is even required--should it be removed as part of 0005012?)

f) Tools > Options > Library:
[Monitor Selected Folders For Changes:] (Note: probably no fix is required--just a question of updating the English sources)

6) I cannot replicate this, but REIKA has verified this on a couple of user's machines. The following item is displayed wrong in Japanese translation:
 
 (View > Toolbars > Configure)
[Standard]
 
See: http://img78.imageshack.us/my.php?image=allhs9.png
 
In addition, the name of the toolbar which user added newly is not displayed normally, too. (please see mm31bug_tb2.jpg.)

petr

2009-01-13 21:56

developer   ~0016192

Fixed in 1213 (confirmed by Reika).

rusty

2009-01-14 16:56

administrator   ~0016203

7) New issue report by REIKA and confirmed by me:

DB.PO contains 'Very Fast' but MM contains 'Very fast'. The net effect being that the string doesn't get localized.

DB.PO should have 'Very fast'.

petr

2009-01-14 19:56

developer   ~0016206

Item 7 fixed in 1214

rusty

2009-01-21 16:50

administrator   ~0016338

Last edited: 2009-01-21 19:24

Translators are reporting the following issues with translation files 1216b:

8)a) Context help for Searchbar is missing one line (Due to problems with extended ascii in the source file): A : finds tracks with A* or รก*
--change to-->
A : finds tracks with A*, a*, or variants with an accent
b) The context strings for the searchbar shouldn't be separated into multiple strings.

9) Some last.fm strings aren't included in the .po file, and don't get translated even if manually added to default.po:
[Last.fm Service]
[Last.fm Profile]
[Refresh]
[Show Log File]
[Clean Cache]

Both of these issues are sufficiently minor that I won't ask translators for another update, however, it would be a good idea for me to post 1216c for any translators that haven't yet begun their work.

petr

2009-01-21 17:36

developer   ~0016340

Items 8&9 are fixed in 1217.

stephen_platt

2009-02-21 16:08

developer   ~0016859

verified 1224