View Issue Details

IDProjectCategoryView StatusLast Update
0005043MediaMonkey (current)Main Panel/Toolbars/Menuspublic2008-12-31 18:27
Reporterstephen_platt 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1Fixed in Version3.1 
Summary0005043: Genre delete / refresh issue
DescriptionReproduce as follows:

1. Take any track, add genre "AAA" and "AAB" (my genre read: Rock; AAA; AAB)
2. Expand the "Genre" node
3. Find genre "AAB", and click on it. Hit F2, then delete, then press enter.
4. Click on Genre "AAA". It is now empty, though the original track is still tagged with AAA. Hit F2 on genre "AAA", delete, enter.
5. Collapse and expand the genre node again. AAA reappears with the track listed.

FYI: I tried to reproduce in the "Artist" node but it does not seem to be an issue there - seems only to affect the Genre node.
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=3235&departmentid=2&ticketstatusid=1
TagsNo tags attached.
Fixed in build1206

Relationships

related to 0005034 closedjiri Encoder version info added to multiple incorrect fields (regression) 
related to 0005109 closedpetr Delete command doesn't work for Composer node 

Activities

rusty

2008-12-16 22:17

administrator   ~0015678

easily reproducible, and extremely confusing. Set to 'immediate'.

jiri

2008-12-17 12:14

administrator   ~0015700

Fixed in build 1203.

Teknojunky

2008-12-30 18:46

updater   ~0015875

peke mentioned this might be the same issue, I am having a problem removing several items from the conductor & composer fields @ http://www.mediamonkey.com/forum/viewtopic.php?p=181710#p181710

I can not remove either by using f2 & clearing the entry, or directly deleting the node from the tree, they keep returning when closing/expanding the node.

I have uploaded a database @ http://www.sendspace.com/file/jx2flg if it would be useful to try it directly.

Teknojunky

2008-12-30 18:47

updater   ~0015876

see my added note

Teknojunky

2008-12-30 18:49

updater   ~0015877

the specific entries I am trying to remove are:

FLAC 1.2.1
iTunes v4.2.0.74, QuickTime 6.5
reference libFLAC 1.1.0 20030126
reference libFLAC 1.1.2 20050205
reference libFLAC 1.1.4 20070213
reference libFLAC 1.2.0 20070715
reference libFLAC 1.2.1 20070917

Teknojunky

2008-12-30 18:53

updater   ~0015878

I set related to http://www.ventismedia.com/mantis/view.php?id=5034 due to these entries were added to the database because of that issue.

jiri

2008-12-30 22:50

administrator   ~0015882

Fixed in build 1206.
 - The were some incorrect links in the database, caused by some DB corruption. Hard to say, what was the source, since DB triggers should ensure consistency of this. However, I added a fix for this to DB Maintenance function, unused items are removed then.

Teknojunky

2008-12-31 16:54

updater   ~0015924

appears to be fixed, thanks

rusty

2008-12-31 18:27

administrator   ~0015925

Verified 1207:
-Incorrect metadata can be deleted
-Rescan doesn't yield incorrect metadata