View Issue Details

IDProjectCategoryView StatusLast Update
0005040MediaMonkey (current)Install/Configpublic2010-10-13 22:30
ReporterBex 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0 
Target Version4.0Fixed in Version4.0 
Summary0005040: MM3's DB and INI location causes problems for roaming profiles
DescriptionAs describer here:
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=34987

Currently MM3 uses Local Settings to store the INI but Local Settings does not get written back to the server with roaming profiles, so all changes are lost at logout. Manually changing the location to Program Files\MediaMonkey\ folder works for one user only, but it's no good if more than one user uses the machine, which is highly likely with roaming profiles.

In 2.5 this wasn't an issue since My Documents was used which works with roaming profiles.

How can this be solved so it doesn't interfere with non-roaming users etc?
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=20832
Tagstodoc
Fixed in build1313

Relationships

related to 0006474 closedLudek Regression: CD Insertion fails to import CD metadata 

Activities

jiri

2008-12-17 15:17

administrator   ~0015704

There is a workaround added by 0005036. So I'm resolving this for now, but we have to review multi-user environment usage in the next version.

Teknojunky

2008-12-17 23:37

updater   ~0015713

by using C:\Documents and Settings\User\Application Data instead of local settings, all of the settings should work fine with roaming profiles.

This was discussed quite awhile back during mm 3.0 alpha/beta when the ini/db location was changed.

I will see if I can dig up the thread.

Teknojunky

2008-12-17 23:39

updater   ~0015714

here is the thread I was referring to

http://www.mediamonkey.com/forum/viewtopic.php?
f=6&t=19763&hilit=+local+settings

Teknojunky

2008-12-17 23:42

updater   ~0015715

not sure if this should be changed to feedback or not, but check additional notes

Ludek

2009-11-11 13:32

developer   ~0019665

Last edited: 2009-11-11 13:34

As discussed with Jiri, we should change the MM.DB and MM.INI location to just
C:\Documents and Settings\User\Application Data
because default scripts location will be there for 4.0 too (implemented as 0004912) and because of the reasons noted here (profile roaming)

jiri

2009-11-26 16:25

administrator   ~0019780

Based on the discussion so far, it really seems to make sense to move DB and INI the described way.

Ludek

2009-11-27 16:34

developer   ~0019794

Fixed in build 1301.

At start user is promted to import MM.DB from MM3 (Local AppData) location to MM4 (AppData) location.

MediaMonkey.ini is copied without a prompt.

Both files are just copied (not moved) so that MM3 can still run on the same machine along with MM4.

jiri

2009-11-27 16:40

administrator   ~0019795

Is there any prompt necessary? I think that it could be done silently, as is the standard DB upgrade done.

Ludek

2009-11-27 18:27

developer   ~0019797

Ok. We could do this without a prompt. I only wanted to made it consistent with the MM2 to MM3 upgrade.

Ludek

2009-11-28 12:08

developer   ~0019798

Fixed in build 1301.

rusty

2010-09-22 15:29

administrator   ~0020566

Per offline discussion:
MediaMonkey.m3u would better be in the roaming profile (but VCD and Previews are probably better in the local one, since they can be huge).

To summarize, that means that:
- MM.DB, MediaMonkey.ini, Extensions, MediaMonkey.m3u in the AppData folder (roaming profile)
- VCD, Previews, in the Local AppData folder (local profile)

See: 0006474 re. CDPlayer.ini

Ludek

2010-09-23 11:19

developer   ~0020567

Fixed in build 1313.

peke

2010-10-13 22:30

developer   ~0020746

Verified 1315