View Issue Details

IDProjectCategoryView StatusLast Update
0004410MediaMonkey (current)Properties/Auto-Toolspublic2010-12-10 23:46
Reporterpeke 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version4.0 
Summary0004410: Tags (all attributes) are written even nothing is changed in Properties.
DescriptionAccording to ticket http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=140
which behavior I can confirm rating is updated in file (when the rating is set to 78 or 79 instead of 80, MM 'corrects' it to 80).

But it should be ignored and not written.
Additional InformationAlso reported here: http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=8148
TagsNo tags attached.
Fixed in build1329

Relationships

related to 0006981 closedLudek Tagging changes do not persist (regression) 

Activities

peke

2008-02-19 22:50

developer   ~0013186

Assigning to Rusty to confirm Bug.

rusty

2008-03-19 20:34

administrator   ~0013389

Jiri, any reason for this? (note: I haven't tried to reproduce this since Peke has already confirmed that the issue exists).

jiri

2008-03-21 14:47

administrator   ~0013443

I think that it has always been this way - i.e. if user clicks OK, all values in text boxes (even if nothing has been changed) are applied, stored in DB and updated in tags. Anything else would require more complex handling, and would probably rather be a source of problems.

rusty

2008-03-21 19:01

administrator   ~0013453

I think we've discussed this issue wrt album art and concluded that this is something that we should eventually fix. i.e.

The only time that a field should be saved is when that particular field has changed.

This implies that:
-Tags shouldn't be updated when clicking Arrows on the property dialog
-Tags shouldn't be updated when clicking 'Ok' unless specific attributes have changed

jiri

2010-10-18 23:42

administrator   ~0020847

This would be a nice to have for MM 4.0 - i.e. to compare the new and the old values and perform the save only in case there has been any change.

Has to be thoroughly tested for regressions!

peke

2010-10-19 02:54

developer   ~0020853

Possible solution would be to Use one Boolean that will control/check if user Changed value of each Edit Field while user is focused on field instead of comparing all tag data on pressing arrows or OK.

Like you said this needs to be toughly tested.

Ludek

2010-11-26 15:45

developer   ~0021490

Raised to immediate, because due to 0006382 this is quite annoying issue.

peke

2010-11-26 18:52

developer   ~0021494

I wonder we add brute-force Metadata length value along with edited boolean flag returned from properties dialog (in most cases it already catches when field is edited or checkbox is checked) could that be faster than comparing each field independently?

Ludek

2010-11-26 20:18

developer   ~0021496

Fixed in build 1329.

peke

2010-12-10 23:46

developer   ~0021725

Verified 1333