View Issue Details

IDProjectCategoryView StatusLast Update
0003279MediaMonkey (current)Main Panel/Toolbars/Menuspublic2010-10-11 01:22
Reporteruser_Dale 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version4.0 
Summary0003279: back and forward mouse buttons should work for navigating
DescriptionThe back and forward buttons on many mice should work like the back and forward navigation buttons in the navigation panel).
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=45317
TagsNo tags attached.
Fixed in build1301

Relationships

related to 0002430 closedLudek Handling Multimedia Keyboard APPCOMMAND_MEDIA Keys sometimes misses 

Activities

rusty

2008-11-25 15:03

administrator   ~0015118

Jiri, is this trivial to implement?

jiri

2008-11-25 17:42

administrator   ~0015122

Assigning to Petr to review whether it's easy to do.

peke

2009-12-22 01:58

developer   ~0019878

Reminder sent to: Ludek

I think I commented Mouse Catches while creating sources for 0002430 due the fact they were slowing down MM.

Maybe it is worth to recheck?

Ludek

2009-12-22 10:21

developer   ~0019879

Yes, it shouldn't be hard to implement.
Assigning to me to implement. I will buy such a mouse and test on it.

peke

2009-12-22 13:10

developer   ~0019881

Last edited: 2009-12-22 13:12

I suggest you to buy one of A4 Tech mouses like (X710BF, X748k, X6???) as their app allow you to assign any multimedia commands (APPCOMMAND) to ButtonX (it is recognized like that in RAWInput)

Check http://www.a4tech.com/

Ludek

2009-12-22 16:30

developer   ~0019883

Last edited: 2009-12-22 16:30

I guess that APPCOMMAND_BROWSER_BACKWARD, APPCOMMAND_BROWSER_FORWARD messages are't the problem here, because they work fine now.

I guess that problem is with the HID mouse RawInput messages. It should be easy to add. I asked Martin that owns mouse with Back/Forward keys for testing in order to resolve this.

Ludek

2010-01-12 20:55

developer   ~0019935

Last edited: 2010-01-12 22:32

Martin said that he has the Logitech MX518 and yes it shows 'Browser Forward'/'Browser Back' when buttons are used in the Hotkey edit box.

This indicates that I don't need the mouse, it is just about adding 2 new default hotkeys/actions.

Ludek

2010-01-12 22:31

developer   ~0019937

Last edited: 2010-01-12 22:37

Fixed in build 1301.

Added new hotkey actions:
'General: Go te Next view'
'General: Go te Previous view'
and corresponding default hotkeys.

Tested on my multimedia keys keyboard.

peke

2010-10-11 01:22

developer   ~0020720

Verified 1315