View Issue Details

IDProjectCategoryView StatusLast Update
0003189MediaMonkey (current)Main Panel/Toolbars/Menuspublic2010-10-25 13:12
Reporteruser_Dale 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.5 
Target VersionFixed in Version4.0 
Summary0003189: it is more convoluted then it needs to be to hide a column
Descriptionright clicking on the tracklist's headers allows you to choose what columns to hide and show. However, it is common to actually click directly on the column you want to hide as it is obviously what you are focusing on at that moment.

Therefore, the first option on the right click context menu should be "hide this column".

also, the list of columns in this right click context menu should be ordered in a more logical manner (ie. the custom fields are not grouped together)
TagsNo tags attached.
Fixed in build1301

Relationships

related to 0000553 closedpetr Enable Basic Tree / Column customization 

Activities

user_steegy

2007-06-26 12:00

updater   ~0009590

As it is now, the header context menu is one long column that needs scrolling on some screens.
Therefore it would be nice to show the header context menu instead:
- in multiple columns
or
- with only the most 'important' items on it, and e.g. a "Show more..." item at the bottom/top. That item would open a dialog, in which users can set the visibility/order of all columns at once.

jiri

2008-11-27 14:22

administrator   ~0015186

Assigning to Rusty for a review and prioritization. I agree that 'Hide This Column' command could be added, but we particularly need a column editor, where user could easily show/hide/reorder all columns.

rusty

2008-11-27 17:51

administrator   ~0015196

Last edited: 2008-11-27 17:52

Re. column hiding, I think that should be implemented 'urgently' or 'immediate'ly since it seems trivial to do so.

note: wording should be 'Hide this column'

Re. column editor, I think we have this already via the 'Choose columns' option.

jiri

2008-11-28 19:35

administrator   ~0015246

Assigning 'Hide this column' feature to Petr.

petr

2010-01-24 02:14

developer   ~0019976

'Hide this column' added in 1301

stephen_platt

2010-10-25 13:12

developer   ~0020946

verified 1318