View Issue Details

IDProjectCategoryView StatusLast Update
0003143MediaMonkey (current)Properties/Auto-Toolspublic2009-10-13 13:42
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.1 
Summary0003143: Write ratings tags in a format that can be read by WMP/MP3 Tag
DescriptionSome users have asked that MP3 tags be written with in such a manner that WMP can read the ratings.

Information about how to do this is at: http://forum.taglib-sharp.com/viewtopic.php?f=7&t=36
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=35331
Tagstodoc
Fixed in build1209

Activities

jiri

2007-06-24 09:28

administrator   ~0009552

We have it already implemented this way, i.e. we read/write data in POPM frame. The only problem is with that rating structure they describe:

0 Star = 0x00
1 Star = 0x01
2 Star = 0x40
3 Star = 0x80
4 Star = 0xC4
5 Star = 0xFF

It's very weirdly chosen, we can't use it exactly this way for compatibility reasons.

rusty

2007-07-09 20:18

administrator   ~0009671

Other users have complained about this issue for other audio formats as well. See:
http://www.mediamonkey.com/forum/viewtopic.php?t=18950

Re-opening for future discussion--this appears to be a significant issue for our users.

rusty

2007-07-09 21:34

administrator   ~0009675

Assigning to Jiri to investigate whether there's a possible approach that would:
-not necessarily be backwards compatible with 2.x, but allow ratings stored in a 2.x DB to be migrated
-continue to support a 10-point system
-be compatible with WMP/MP3Tag/other apps for MP3 and WMA
-be compatible with MP3Tag/other apps for FLAC/OGG

rusty

2007-12-03 18:23

administrator   ~0012269

Note: I tested Vista and it seems to read MM-tagged tracks properly (with the correct rating). However, tracks that are tagged by Windows Explorer in Vista aren't read correctly by MM.

See: http://www.mediamonkey.com/forum/viewtopic.php?t=22908

peke

2008-12-25 04:40

developer   ~0015810

Added Forum topic explaining some aspects of Rating

Owyn

2008-12-26 11:18

updater   ~0015813

Confirm that WMP11 reads MM Rating tags. The half ratings are shown as full, but that is a WMP deficiency.

I have been WiMPing out and using WMP11 to safely play audio while working on MM3 changes.

Also did some testing of using WMP's AMG based Find Album Info to get data for Composer tags. That works, but, WMP can mangle album art for MM.

rusty

2008-12-26 20:19

administrator   ~0015815

Raising to 'immediate' for the issue that Explorer ratings aren't read correctly by MM.

The other issue of WMP failure to read MM tags should be examined concurrently, but can be considered 'urgent'.

jiri

2009-01-07 12:04

administrator   ~0016046

Last edited: 2009-01-07 12:06

Fixed in build 1209.
 - I modified mp3 rating storage so that it's as compatible as possible with WMP and Explorer (and thus probably also some other applications). Both directions work well, half-star ratings in MM are rounded up for WMP and Explorer.
 - I haven't made any changes for FLAC or other formats, since there isn't any clear standard. We would need to evaluate as many applications as possible in order to check out, whether it makes sense to somehow switch to numbers 1-5 as used by some apps.

stephen_platt

2009-02-23 02:16

developer   ~0016912

verified 1224

rusty

2009-10-13 13:42

administrator   ~0019137

We should document: http://www.mediamonkey.com/forum/viewtopic.php?p=217410#p217410