View Issue Details

IDProjectCategoryView StatusLast Update
0002937MediaMonkey (current)Synchronizationpublic2011-02-07 04:50
Reporterrusty 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version4.0 
Summary0002937: Auto-Sync: Isn't useful for selecting some types of Music (e.g. classical, unsubscribed podcasts)
DescriptionThe Auto-sync panel doesn't allow the user to select tracks based on attributes that are needed for certain types of music (e.g. Composer, Artist, Genre, etc.).

The ideal implementation would be that the Sync list mirrors the node settings that the user has chosen for the Library subnodes of the default filter (perhaps not including Title, Files to Edit, Virtual CD, and Previews).

Alternatively, we could just add the following nodes: Artist, Album Artist, Composer, Year, Genre (note: the reason for including Artist is because classical music is sometimes tagged with Artist=Composer, which makes the Album Artist&Artist node useless for selection purposes).

When we implement this, we'll want to add support for playlist generation based on these other attributes (needed for non-iPod devices).
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?t=16322

http://www.mediamonkey.com/forum/viewtopic.php?t=23288
TagsNo tags attached.
Fixed in build1312

Relationships

related to 0003373 closedLudek Auto-sync list: cleanup in relation to support for multiple types of content & filters 
related to 0004258 resolvedLudek Unify code for live size indicators (burning and device sync) 
related to 0005824 closedLudek Device configuration: Simplify Sync-list layout 

Activities

jiri

2009-09-09 10:02

administrator   ~0018757

Resolution of this depends on 0005824, so assigning to Rusty until it's decided.

Ludek

2010-09-08 18:57

developer   ~0020495

Last edited: 2010-09-08 18:58

View 2 revisions

This is already implemented in build 4.0.0.1312 according to this UI proposal:
http://www.ventismedia.com/mantis/file_download.php?file_id=494&type=bug

stephen_platt

2011-02-07 04:50

developer   ~0022875

verified 1346