View Issue Details

IDProjectCategoryView StatusLast Update
0017139MediaMonkey 5Generalpublic2020-12-12 12:07
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0017139: UAC Dialog Shows even on MM5 portable if MM5 is used alongside with MM4
DescriptionUAC Dialog Shows even on MM5 portable if MM5 is used alongside with MM4 each time MM5 is started if last used MM was MM4.
TagsNo tags attached.
Fixed in build2277

Relationships

related to 0015176 closedLudek Playing from portable version to a renderer may fail (as portable version doesn't auto-conf firewall) 
related to 0017209 closedLudek UAC prompt is shown after every re-install (also in Portable mode) 
related to 0017219 closedLudek Blocked connection dialog is shown before user even accepts the import settings from MM4 dialog 

Activities

peke

2020-11-27 14:00

developer  

1606217329649.JPEG (164,190 bytes)   
1606217329649.JPEG (164,190 bytes)   

petr

2020-11-27 15:00

developer   ~0060398

Just tried and elevator prompt appear only when clean install was run for a first time (because of Firewall setting).

peke

2020-11-27 23:41

developer   ~0060407

Can you see with Ludek if for MM5 we can move registering of firewall and starting DLNA server based on wizard settings? eg. If enabled then ask for UAC+start DLNA Server (includes if wizard is canceled as DLNA is enabled by Default). I think that essentially first time start experience would be same, but would also avoid non needed firewall rules created (just checked and I had over 50 rules created from various installations and during UI and portable tests i usually disable UPnP)

Many users complained about MM5 portable asks for UAC permissions.

Ludek

2020-11-30 08:41

developer   ~0060455

Last edited: 2020-11-30 08:42

View 3 revisions

I can confirm that MM is adding the firewall rules also in case of Portable (because of 0015176 )

But you seem to be true that currently MM is creating the rules even when no media server runs (sharing is disabled and user isn't using UPnP/DLNA access at all).

=> Fixed in 2277.

i.e. MM now adds the firewall rules only on MM server start (when MM server is starting for sharing, syncing or a MM local file is played to a renderer).

peke

2020-12-02 23:51

developer   ~0060512

Verified 2277

No nagging UAC prompt now.