View Issue Details

IDProjectCategoryView StatusLast Update
0016240MediaMonkey 5[All Projects] Generalpublic2020-01-22 23:21
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0016240: Playback: Playback fail on all tracks
DescriptionFor Unknown reason for this user playback fails on all tracks and deleting INI file, along with changing Output plugins and output Devices (he have more than 5 Playback devices) unlocks it.

INI File that fails is supplied in ticket.
Additional InformationACP-241-56468
TagsNo tags attached.
Fixed in build2220

Relationships

related to 0006469 closedLudek MediaMonkey (current) Make WASAPI output plug-in default, with a fall-back to DS 
related to 0016241 closedmichal MediaMonkey 5 Double-clicking output plugin does not open configuration 
related to 0016270 resolvedmichal MediaMonkey 5 Playback Stops 
related to 0015681 assignedmichal MediaMonkey 5 Provide user feedback in cases of failed tagging / playback 

Activities

Ludek

2020-01-07 10:39

developer   ~0055811

Last edited: 2020-01-07 11:00

View 8 revisions

From the "MMW Not PLaying LOG 1.LOG" I can confirm that there are 7 output devices and that WASAPI fails to play the files:

00021748 78.34133148 [161552] WASAPI: Output thread is starting
00021749 78.34142303 [161552] WASAPI: Looking for device: {0.0.0.00000000}.{c137d1af-7f4f-456e-8e09-ff3e6211e7b8}
00021750 78.34320068 [161552] WASAPI: Default device: {0.0.0.00000000}.{c137d1af-7f4f-456e-8e09-ff3e6211e7b8}
00021751 78.34553528 [161552] WASAPI: Found device: {0.0.0.00000000}.{2dbf64a2-83cb-451a-9bdd-7d41808911c8}
00021752 78.34557343 [161552] WASAPI: Found device: {0.0.0.00000000}.{6740ea00-f982-4316-accb-5ef0647a9b34}
00021753 78.34564209 [161552] WASAPI: Found device: {0.0.0.00000000}.{9fa538f1-ab64-4ec9-9c44-ec1b8bba2626}
00021754 78.34571075 [161552] WASAPI: Found device: {0.0.0.00000000}.{b89ba74c-e3ff-4a5e-b5b4-fbd6eeb32254}
00021755 78.34577179 [161552] WASAPI: Found device: {0.0.0.00000000}.{bfc9cf88-a81d-4d3d-8252-1723b9cce94f}
00021756 78.34584808 [161552] WASAPI: Found device: {0.0.0.00000000}.{c137d1af-7f4f-456e-8e09-ff3e6211e7b8}
00021757 78.34638214 [161552] WASAPI: Using automatic format choice.
00021758 78.34656525 [161552] WASAPI: Best format for playback found: 44100kHz, 2 ch, 16 bps
00021759 78.34662628 [161552] WASAPI: No output format for automatic exclusive mode was found.
00021760 78.34670258 [161552] WASAPI: New track not starting, finishing playback thread.
00021761 78.34674835 [161552] WASAPI: MMOpen finished.

While MMDS plays it (MMW PLaying LOG 2.LOG)

There used to be fallback to MMDS when WASAPI fails, but this was subsequently reverted ( details in 0006469 )
Note that WASAPI is the default only on Win10+ (details in #16009)

We could add the fallback to MMDS back, but you indicated in #16009 that Win10+ distanced itself from DS ?
And supposing that only a small set of users is observing this I guess that our KB article is enough, I see it covered e.g. as item 2b here: https://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/88/0/no-sound-is-playing--sound-is-corrupted

Ludek

2020-01-07 13:08

developer   ~0055813

Resolving, as discussed offline with Peke it was related to user's drivers/devices/system config and sometimes even changing to MMDS did not work and once it worked then also WASAPI started to work.
So nothing that we could fix in MM.

Ludek

2020-01-07 13:16

developer   ~0055814

Last edited: 2020-01-07 13:30

View 5 revisions

Re-opened:
Upon offline discussion with Peke it would be useful to add an error dialog when playback fails because of an output plugin issue like this.
Currently the tracks are only greyed out and skipped and users/support team have no idea what's happening.

Assigned to Rusty to suggest wording for such a dialog, something like:
"Current audio output configuration has trouble to play file X. Ensure that your sound drivers are properly installed or try to change/configure your output plugin."
[Configure] [Help] [Cancel]

[Configure] could be a link to Options > Ouptut plugins
[Help] could point to https://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/88/0/no-sound-is-playing--sound-is-corrupted

rusty

2020-01-07 17:56

administrator   ~0055818

How about:
"Current audio configuration cannot play xxx.yyy. Verify that your sound drivers are properly installed or try to change/re-configure the output plugin."

The [Help] button should link to: https://www.mediamonkey.com/mediamonkey-output-error
(redirects are used rather than direct links in case of a change to the back end).

Ludek

2020-01-07 21:58

developer   ~0055819

Sounds good, targeted to 5.0

Ludek

2020-01-08 12:19

developer   ~0055823

Last edited: 2020-01-08 12:20

View 2 revisions

Added in 2220. The dialog looks like this:



ouput.png (56,478 bytes)
ouput.png (56,478 bytes)

peke

2020-01-15 01:57

developer   ~0055851

Verified 2220

Dialog is properly shown.

Test case: It is easier when using BT Audio where you can simply just go out of BT range or turn the Headphones off.