View Issue Details

IDProjectCategoryView StatusLast Update
0014063MediaMonkey (current)Properties/Auto-Toolspublic2017-03-04 00:53
Reporterpeke 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target Version4.1.16Fixed in Version 
Summary0014063: MP3 Tags: MM fail to read MP3 Tags if APE tag is present in file
DescriptionIf MP3 file contain non standard APE tag at the end on file MM fail to read TAG.

APETAGEX Chunk should be ignored and removed on tag save.

Sample file is uploaded to FTP
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=87255
TagsNo tags attached.
Fixed in build

Relationships

related to 0014064 feedbackrusty MediaMonkey 5 Improve Tag Management 

Activities

michal

2017-03-03 15:09

developer   ~0047390

The sample file has correct ID3v2 tag, then second ID3v2 tag (values from this second tag overwrite values from the first, that is why MediaMonkey shows some "wrong" tags), then ID3v1 tag, then non-standard APETAG and then another ID3v1 tag at the end of the file. So the problem is not in the APETAG itself, but in this whole mess.

michal

2017-03-03 15:43

developer   ~0047391

The problem could be resolved by specialized software for fixing such corrupted files before importing them to MediaMonkey. MP3Val ( https://sourceforge.net/projects/mp3val/ ) seems to do it.