View Issue Details

IDProjectCategoryView StatusLast Update
0014048MediaMonkey 5Main Panel/Toolbars/Menuspublic2019-09-26 17:53
Reporterpeke 
PriorityurgentSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0014048: TV Series: Browser View
DescriptionTV Series browsing is faulty and do not provide any useful information unlike Music Album Browser view making it more consistent with other types.

Attached Current UI and Changes that would show correct information and data
TagsNo tags attached.
Fixed in build2202

Relationships

related to 0013756 resolvedpetr Add/Rescan: Add additional Column of preffered/expected content type 
related to 0012481 resolvedLudek Metadata Support: Common External metadata support 
related to 0012423 newrusty Improved per-Type behavior: Auto-tag from Filename masks should be per Type 
related to 0014077 feedbackmichal Review Movies handling/presentation 
related to 0014269 closedpeke Type Detection: TV Series 

Activities

peke

2017-02-27 23:09

developer  

TV Series Current.jpg (224,680 bytes)
TV Series Current.jpg (224,680 bytes)

peke

2017-02-27 23:09

developer  

TV Series New UI.jpg (209,867 bytes)
TV Series New UI.jpg (209,867 bytes)

peke

2017-02-27 23:10

developer  

TV Series Listing.jpg (31,991 bytes)
TV Series Listing.jpg (31,991 bytes)

peke

2017-05-20 01:23

developer   ~0047998

Recent findings found out that TV Series and most likely some other types should have Bookmarking Enabled.

Bookmarking should be saved so that MM5 know exact Season/Episode/EpisodeTime was last played if play was initiated from Grid view. and should have 5 Min delay in case different file is played before new bookmark is set.

Otherwise Bookmark is also saved per episode(eg file).

lowlander

2017-06-08 17:20

developer   ~0048100

Last edited: 2017-06-08 17:34

View 3 revisions

First View would be a list of all Series. This would show Artworks for each Series and Title (Date (year of first airing)).
A second View would be Artworks with Description which would show Series Artwork, Title, Date, Season Count, Episode Count, Parental Rating and Genre.
The Third View would be a List view which would have all Series related Columns available for users to enable.

Second View should be Series, with Series description and Artworks for each Season (and Episode Count per Season). This View should have a second option to list all Episodes associated with the Series.
It should show Show name, Date (Year of first episode), Show Status (if show is still being broadcast/ended), Parental Rating, Genre, Rating, Description, Studio, Episode Count & Season Count (would be nice if MM could show in DB/total known for both, but this would need to be refreshed often), Channel (Station of original broadcast), Cast, Size (File size). It should also show Continue Watching if any Episode has been played and state which Episode would be continued (Season#/Episode# -Title).
In this View the Play button would start Playing the first unwatched or Bookmarked Episode in the database.

Then you'd click a Season to load the Season view which would show the Season Cover (not Series) and the Episodes associated with that Season of that Series. Series Description can be left as there are no Season Descriptions. The Episode list should be available as a pure list as well as a thumbnail (auto-generated from file or online retrieved) view that states the Episode Title and Episode #.
Episode lists should include Episode #, Title, Air Date, Rating, Duration, Watched (a graphic indicator if user watched the Episode) Time Remaining (if file has a Bookmark/use partially watched Watched indicator). The third View would be a Episode Artwork with Episode #, Title, Air Date and Description.
In this view each Episode should have a Play button (can be hidden to mouse over) which would be more pleasant that right click Play Now.

Then you'd click through to the Episode View which would include Epsiode Artwork, Title, Season #, Episode #, Parental Rating, Duration, Air Date, Director, Writer, Episode Cast (if such info exists) Description, Rating, Audio (with option to select which for multi-audio files), Subtitles (with option to select which if multiple subtitles exist).
This view should have a Play button and play the shown Episode.

If a Bookmarked Episode is starting to Play MediaMonkey should prompt to Continue Watching from Bookmark (and show at what time this is) or Start Watching from Beginning. This prompt should have an Option in the Settings to Always Start at Bookmark/Always Start at Beginning/Prompt.

jiri

2017-07-13 15:49

administrator   ~0048363

At least basics of the ideas described here should be implemented for MM5, anything remaining for MM5.1.

rusty

2017-09-13 15:21

administrator   ~0048739

Briefly tested build 2076. Key functionality described at 0014048:0048100 that should be implemented:
- Display of bookmark status (i.e. was a track watched/watched partially). e.g. similar to MMA.
- Display of episode metadata

The following issues exist with the current functionality:

1) Breadcrumbs bar shows: Home > TV > Albums > ShowName. It should indicate Series instead of Albums

2) The context menu options are for Type:Music. i.e. Play, Shuffle, Overflow [Wrong Album, Wrong Release, Properties, Edit Album in MusicBrainz, Edit Release in MusicBrainz, Pin it].

For Type:TV this should be something like Play, Overflow [Update metadata, Properties, Edit in TVDB]

Note: this probably applies to Type:Movies as well.

3) If the user manually edits the Type for a series of videos from Video to TV, then the series is listed without any description, and there's no obvious way of getting a description to appear. Ideally, a description would appear automatically exactly as it does for Albums.

Another alternative would be that whenever the Type of a file is changed, MM should perform both Metadata lookup and inference based on the new Type setting.

4) If the series name is long, then it appears _below_ the artwork, but it appears cut off (see attached).

5) For Type:TV, in cases where Episode# and Season# are missing but it exists within the Title, MM should (either):
a) infer Season/Episode from the structure of the title (I suspect that this would be easier to implement, and could be made to apply globally more easily).
b) correctly sort titles using the metadata (Note: this should apply throughout MM for title sorts)

e.g. For
Batman S01E01
Batman S01E02
Batman Season1E01
Batman Season01E2

MM should be able to 'understand' that:
Season=S
Episode=E=Ep.
Episode/E/Season/S may be followed by the # directly, or by a ' ' or '.' and then the number
01=1 and both of those precede 10,11
xofy: x=Episode#, and y=Total #Episodes

rusty

2017-09-13 15:36

administrator  

jiri

2017-10-23 11:48

administrator   ~0049033

5) Is already fixed according to Ludek.

michal

2018-02-11 16:40

developer   ~0049612

Mostly fixed in build 2090, resolving to test. After discussion with Jiri, I did not implement season artworks and related. Currently we have Series on the same level as Album, and Season# on the same level as Disc#. So seasons are displayed grouped the same way as discs (season number is displayed in the group header). I think it could be sufficient.

peke

2018-03-06 23:41

developer   ~0049687

Last edited: 2018-03-07 01:06

View 4 revisions

Reopen, due the instability (crash) and mostly non usable on larger Series.

Season Album View isn't specific to TV Series and even for multi CD collection like my KuschelRock collection that consist of 28 Volumes with 2-3 CDs each where I have Album art for collection and for each volume can benefit from such view.

Same goes for multi CD collection where Bonus CD is Live

I uploaded Video File to FTP for analyze and re evaluation.

Also Artist view (Picture uploaded to ftp) is much better view for TV Series than existing one where:
ARTIST (FROM-TO) >>> SERIES TITLE (FROM-TO)
ALBUMS >>> SEASONS

peke

2018-03-07 01:04

developer  

bug14048.jpg (161,260 bytes)
bug14048.jpg (161,260 bytes)

michal

2018-03-08 08:32

developer   ~0049693

Crash (seen in uploaded video) fixed in build 2091.

peke

2018-03-16 21:49

developer   ~0049731

Last edited: 2018-03-16 21:50

View 2 revisions

Verified 2091 (no more crashes)

rusty

2019-09-11 20:26

administrator   ~0054596

There are a couple of items that still must be fixed for 5.0:
A) For some reason many movies are assigned a 'Series' based on the folder that they're in . This shouldn't be the case, since movies are often contained within a single Folder even though they're not part of a series.
B) Endless hourglass whenever a Series is:
- a single movie
- a series that contains Seasons x-y. e.g. If MM shows a series as 'Breaking Bad Seasons 1-2' then an endless hourglass results when clicking the series

peke

2019-09-26 12:11

developer   ~0054859

I think that the only long term solution would be to add Movies Type 0014077 where it can be clearly separated from series.

michal

2019-09-26 17:53

developer   ~0054864

Bugs mentioned by Rusty should be fixed in build 2202. The rest is discussed in related issues.